locked
Incorrect Address or Soap action RRS feed

  • Question

  • i have a Cloud Application with Web role . and a WCF web role service in the same application.

    I am consuming my WCF web role service in web role and it is working fine on my local machine.

    It is deployed on cloud but when i try to test the application it is giving the error:

    There was no end point at http:/localhost:50490/service1.svc that could accept the message. it is caused by an incorrect address or soap action.

    My end point in web role is as follows:
     <client>
       <endpoint address="http://localhost:53278/Service1.svc" binding="basicHttpBinding"
        bindingConfiguration="BasicHttpBinding_IService1" contract="ServiceReference1.IService1"
        name="BasicHttpBinding_IService1" />
      </client>

    If anybody has an idea about this please give me solution..................... 

    Tuesday, September 28, 2010 12:38 PM

Answers

All replies

  • If you want to use WCF service only from within web role,  you could use interrole communication. This is explained nicely on this Cloud Cover show.
    Please mark it as answer by clicking on "Propose As Answer", if it helps
    Tuesday, September 28, 2010 1:24 PM
  • Hi Shevata -

    if you want to deploy it toAzure, the end point can not be poitning to localhost..

    it needs to be something like:

    <client>
       <endpoint address="http://MyAzureService/Service1.svc" binding="basicHttpBinding"
        bindingConfiguration="BasicHttpBinding_IService1" contract="ServiceReference1.IService1"
        name="BasicHttpBinding_IService1" />
      </client>

    Tuesday, September 28, 2010 5:54 PM
  • Correction ...

    it needs to be something like:

    <client>
       <endpoint address="http://MyAzureService.cloudapp.net/Service1.svc" binding="basicHttpBinding"
        bindingConfiguration="BasicHttpBinding_IService1" contract="ServiceReference1.IService1"
        name="BasicHttpBinding_IService1" />
      </client>

    Tuesday, September 28, 2010 5:55 PM
  • Hi

    Actually what i m doing is : my WCF Web Role Service and Web Role are in same application and when i try to add service reference in web role it discover the service at the add ress like this :

    http://localhost:53278/Service1.svc

    On local machine it is working fine but when i try to deploy my application on cloud and at the time where i m am consuming my WCF web role Service in Web Role it shows the error  :

    There was no end point at

    http://localhost:53278/Service1.svc

    that could accept the message. it is caused by an incorrect address or soap action.

    My Question is when Service and web role are in same application, then how to change the Service reference from localhost to a particular Address when i am trying to deploy it on cloud?

     

    Wednesday, September 29, 2010 8:49 AM
  • i know when i  want to deploy it toAzure, the end point can not be poitning to localhost..

    but which address show i define in client endpoint:

    <

     

     

    client>

    <

     

     

    endpoint address="http://localhost:53278/Service1.svc" binding="basicHttpBinding"

     

     

     

    bindingConfiguration="BasicHttpBinding_IService1" contract="ServiceReference1.IService1"

     

     

     

    name="BasicHttpBinding_IService1" />

    Wednesday, September 29, 2010 8:51 AM
  • If you dont have a need to access WCF service other than from the web app hosted in the same cloud application,  you could add an internal end point to the WCF web role and access it through interrole communication using RoleEnvironment class.

    In your current implementation, change http://localhost:53278/Service1.svc to http://MyAzureService.cloudapp.net/Service1.svc in both WCF service and client(your web app in this case) as mentioned by Garry earlier.


    Please mark it as answer by clicking on "Propose As Answer", if it helps
    Wednesday, September 29, 2010 3:08 PM
  • I have tried this but still not working..........
    Thursday, September 30, 2010 5:59 AM
  • Actually i have a Cloud Application and a Web Role and WCF Web Role Service in the same Cloud Application.

    I m consuming my WCf Service in Web Role . On local machine it is working fine . But when i m going to deploy it on Azure it is giving the error:

    There was no end point at http:/localhost:50490/service1.svc that could accept the message. it is caused by an incorrect address or soap action.

    After that i changed the localhost Address as

     http://WCfCloudService.cloudapp.net/Service1.svc

    But still  i m facing same Error..................

    Thursday, September 30, 2010 6:44 AM
  • Hi,

    Could you please try to access  http://WCfCloudService.cloudapp.net/Service1.svc  in browser? What do you see? (before that please remember to set  <serviceMetadata httpGetEnabled="True"/> to enable the HTTP GET support do view metadata in browser http://msdn.microsoft.com/en-us/library/ms731317.aspx)

    You may also refer to this post regarding a similar issue:

    http://social.msdn.microsoft.com/Forums/en-US/windowsazure/thread/a36ca4d2-b8df-48ff-ae39-c8fd70d680c4


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. Windows Azure Platform China Blog: http://blogs.msdn.com/azchina/default.aspx
    Friday, October 1, 2010 5:45 AM