locked
Web.config suddenly stopped displaying colors (intellisense gone) RRS feed

  • Question

  • User844850623 posted

    I have several ASP.NET 3.5 applications, and suddenly the web.config only displays in black and white (and no intellisense), as if it's not being recognized as a proper file. 

    Even new applications I create have the formatting issue in the file.  What would cause this and how do I get it back.

    Thanks
    Jay

    Wednesday, March 18, 2009 9:04 PM

Answers

  • User-2058570687 posted

     <meta http-equiv="CONTENT-TYPE" content="text/html; charset=utf-8"><title></title><meta name="GENERATOR" content="OpenOffice.org 3.0 (Win32)"><style type="text/css"> <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } --> </style>

    It happens when make mistakes in web.config file ie, don't close the xml tags properly etc. The best way to tackle it is to just back up your web.config file and then remove it from your project. Then add a new configuration file to the project and make the changes you want perform.

    You can refer your back up copy for changes you made in the past


    Regards


    Omal

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 19, 2009 2:51 AM
  • User-1285090017 posted

    in your web.config there will be a tag as follows:

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0"> or 3.5

    remove the xmlns and try

    e.g: <configuration>

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 19, 2009 3:22 AM

All replies

  • User993629960 posted

    This happens if web.config is modified using external editor or tool. Close your visual studio & open it again.

    Thursday, March 19, 2009 2:35 AM
  • User-2058570687 posted

     <meta http-equiv="CONTENT-TYPE" content="text/html; charset=utf-8"><title></title><meta name="GENERATOR" content="OpenOffice.org 3.0 (Win32)"><style type="text/css"> <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } --> </style>

    It happens when make mistakes in web.config file ie, don't close the xml tags properly etc. The best way to tackle it is to just back up your web.config file and then remove it from your project. Then add a new configuration file to the project and make the changes you want perform.

    You can refer your back up copy for changes you made in the past


    Regards


    Omal

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 19, 2009 2:51 AM
  • User-1285090017 posted

    in your web.config there will be a tag as follows:

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0"> or 3.5

    remove the xmlns and try

    e.g: <configuration>

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 19, 2009 3:22 AM
  • User-1285090017 posted

    take bakup before doing any changes!!!

     

    Thursday, March 19, 2009 3:24 AM
  • User844850623 posted

    So on further investigation, it's not the xmlns issue, but seems to be all XML files.  Going into VS 2008 =>> Options =>>Text Editor =>> XML =>> Formatting, it says "An error occurred loading this property page".

    I found a post with some similar symptoms, and resloved my issue by running "devenv /setup" from a VS 2008 command prompt.

    Thanks for everyones advice!

    Thanks
    Jay

    Wednesday, March 25, 2009 4:27 PM
  • User1601043016 posted

     

    Really a good one .....It sloved my problem .... thanx .....  but is the cause for this .... any idea

    Wednesday, April 21, 2010 3:26 AM