locked
IIS 7.5 Error 404.0 Not Found RRS feed

  • Question

  • User2139591901 posted
    I've recently encountered an error when accessing a URL saying that it is removed or something of the sort (Runescape). I can load the frontpage, and I can load the client, but I cannot load anything further than that i.e. the forums or highscore tables, etc. Here is the error: HTTP Error 404.0 - Not Found The resource you are looking for has been removed, had its name changed, or is temporarily unavailable. Detailed Error Information Module IIS Web Core Notification MapRequestHandler Handler StaticFile Error Code 0x80070002 Requested URL http://services.runescape.com:80/m=forum/forums.ws Physical Path C:\inetpub\wwwroot\m=forum\forums.ws Logon Method Anonymous Logon User Anonymous I've checked and googled most posts/issues similar to this, but none have given me an answer I can understand. (I have no idea how to operate PHP or anything of the sort). Any help, and or solution is greatly appreciated.
    Friday, June 15, 2012 12:27 AM

All replies

  • User2139591901 posted
    Not sure how to add spaces in between the sentences. My apologies.
    Friday, June 15, 2012 12:30 AM
  • User2139591901 posted
    Anybody?
    Monday, June 18, 2012 6:55 AM
  • User390598869 posted

    Your URL is full off special signs (= .)

    Can you verify you havent a tool like URLSCAN installed which does not allow you to use these special signs?

    Why does your domain ends with :80? Isnt this website staticly bound to port 80?  

    Regards

    Tuesday, June 19, 2012 4:22 AM
  • User2139591901 posted
    Sorry, I'm new to IIS, How do I check if URLSCAN is on? And I'm not sure why the :80, but it wasn't there prior to entering the web address, and I assumed it was the port number it was trying to connect to. EDIT: I should also add that it says Error in the "DEFAULT WEB SITE"
    Tuesday, June 19, 2012 4:28 AM
  • User390598869 posted

    Hi

    URLSCAN is to be found (if installed) in %windir%\system32\inetsrv\urlscan

    How you mean error? Does it have a questionmark or what?

    Tuesday, June 19, 2012 8:01 AM
  • User2139591901 posted
    There is no URLSCAN installed/in the folder. And at the top of the page it says Server Error in Application "DEFAULT WEB SITE". No question marks or anything.
    Tuesday, June 19, 2012 6:09 PM
  • User390598869 posted
    In basic settings for Default Website what is it fysical location specified, is this path fysically there if you browse it?
    Next in Basic Settings, what happens when you click on TEST SETTINGS?
    Wednesday, June 20, 2012 6:37 AM
  • User2139591901 posted
    Yes, there is a physical path: %SystemDrive%\inetpub\wwwroot. And when I click Test Settings I get an authentication saying it's valid, and another message saying: "Cannot verify access to path (C:\inetpub\wwwroot)", even though the path exists. Furthermore, here is the message description: "The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again."
    Thursday, June 21, 2012 7:34 PM
  • User390598869 posted

    Hi

    Maybe you can try to add a user to this server (can be local or domain, up to your config)

    In this scenario we add a local user to the webserver and call it "websiteuser"
    This user needs a long/strong password which off course never expires and the account needs to be member off the group IIS_IUSRS which should have adequate rights (by default) to your website home dir.

    Once the user is added go to IIS, Basic Settings, Connect AS and fill in the userdetails. Now when you click test settings you should get 2 green flags saying rightlevels are correct so you can try your website.

    Hope this helps.

    Friday, June 22, 2012 5:05 AM
  • User2139591901 posted
    Sorry, where is the "add user" button. I'm an extreme newbie when it comes to IIS, so I pretty much need step by step directions on what to do. I apologize if there's an inconvenience.
    Friday, June 22, 2012 7:06 AM
  • User390598869 posted
    On the server, right click my computer and select manage.
    Friday, June 22, 2012 8:01 AM
  • User2139591901 posted
    There is no "manage" button. It says "Manage Web Site", but underneath is simply, restart, start, stop, browse, etc. Nothing about adding a user.
    Friday, June 22, 2012 8:05 AM
  • User390598869 posted
    You need to add the user to Windows, not IIS.
    Friday, June 22, 2012 8:07 AM
  • User2139591901 posted
    I went to Computer Management, and searched for the subgroup "Local Users and Groups" to add a user to the webserver, but the subgroup does not exist. I went to the help menu, and it implies that it should be there, but it's not. Under system tools are only Task Scheduler, Event Viewer, Shared Folders, Performance, and Device Manager.
    Friday, June 22, 2012 8:19 AM
  • User390598869 posted

    Is it a domain controller? If so you need to add the user to active directory Users and Computers.

    Else, what OS are you using?

    Friday, June 22, 2012 8:47 AM
  • User2139591901 posted
    I do not believe so. And it's Windows 7.
    Friday, June 22, 2012 8:49 AM
  • User390598869 posted

    Oops, i didnt see that answer coming :)

    Ok, instead off adding a user just use your username/password in IIS connect as. (assuming you are the local admin) and test your site.

    Friday, June 22, 2012 9:07 AM
  • User2139591901 posted
    Okay I did that, two green flags, but when I went to test the website I still got the same error. Nothing changed really.
    Friday, June 22, 2012 6:39 PM
  • User390598869 posted

    Hmm so we have no rights-issue.... i have to admit windows 7 & IIS is not my strongest thing but i keep thinking about the IUSR.

    You could try to add your website to the trusted websites by going to internetoptions in IE and click on security.

    Else i am thinking, is your web.config in place? are you using the right .net versions for every application? (2.0 or 4.0)?, could it be there is a spelling issue in the URL?

    Please check this URL, it is on the same brainwave i am on.. LINK

    Sunday, June 24, 2012 5:36 AM
  • User2139591901 posted
    I use Google Chrome, how would I add it to the trusted sites if not already? "Make sure that the requested resource is at the location that the URL points to." The location that it points to doesn't exist, which I assume is a problem, but I'm not sure how to create the physical path that leads to it. I tried simply creating a folder and naming it m=forums, but that doesn't really make any sense.
    Sunday, June 24, 2012 7:04 PM
  • User2139591901 posted
    Bump. Issue still unresolved.
    Thursday, June 28, 2012 5:55 AM
  • User521890537 posted

    I think IIS handler is not configured correctly.

    What is the language of your website code?

    On forum folder, test browsing html page to confirm problem is with IIS handler.

    Friday, June 29, 2012 1:38 AM
  • User2139591901 posted
    Forum folder? Where is that located.
    Sunday, July 1, 2012 2:48 AM
  • User2139591901 posted
    Bump. Issue still unresolved.
    Wednesday, July 4, 2012 7:24 PM
  • User2139591901 posted
    Bump again. I attempted to "create" a path as the error states there is no path, but when I do so I receive a new error. HTTP Error 404.3 - Not Found The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map. Detailed Error Information Module StaticFileModule Notification ExecuteRequestHandler Handler StaticFile Error Code 0x80070032 Requested URL http://services.runescape.com:80/m=forum/forums.ws Physical Path C:\inetpub\wwwroot\m=forum\forums.ws Logon Method Anonymous Logon User Anonymous Most likely causes: It is possible that a handler mapping is missing. By default, the static file handler processes all content. The feature you are trying to use may not be installed. The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.) If ASP.NET is not installed. Obviously I knew that something as simple as this solution would not work, but just some additional information. Again, issue unresolved.
    Monday, July 9, 2012 12:01 AM
  • User2139591901 posted
    Issue still unresolved.. :( Can't anybody help?
    Monday, July 23, 2012 7:46 PM