none
New-MigrationBatch AllowUnknownColumnsInCSV not working RRS feed

  • Question

  • I am working on building an automated script for a large on prem to O365 migration.  The script builds CSV files that contain numerous columns for different pieces of data that will be useful to us. These CSVs are used as the source for creating migration batches in PowerShell. 

    For some reason, I am unable to get the parameter -AllowUnknownColumnsinCSV to work. For manual testing purposes of the new batch cmdlet, the CSV I am using only has a single column. I am able to add the -AllUnknownColumnsInCsv parameter with $True and there are no errors but when I look at the resulting batch, it is still set to $false. If I use a CSV with multiple columns, it gives an error in regard to the multiples.  As a test, I used 'Set-MigrationBatch <batch Name> -AllowUnknownColumnsInCsv $true' on one of the batches made with the single column CSV. Again, no errors but the parameter doesn't change.

    The script is being run in the Microsoft Exchange Online Powershell Module.

    This is a piece of the script. At this point I'm not sure if its something I am doing wrong or my logic is flawed, or if there is some type of bug. Any suggestions would be appreciated.

    $OnboardingBatch=New-MigrationBatch-Name$batchName-SourceEndpoint$sourceEP-TargetDeliveryDomainXXXX.mail.onmicrosoft.com-BadItemLimit1000-LargeItemLimit200-NotificationEmailsuser@company.com-CSVData([System.IO.File]::ReadAllBytes("$($l.versioninfo.filename)")) -AllowUnknownColumnsInCsv$true-StartAfter"7/25/2019 2:55 PM"-CompleteAfter"7/30/2019 3:00 PM"

    Thanks,

    Friday, August 9, 2019 12:14 PM

All replies

  • Hello,

    just to be sure, do you have the column "EmailAddress" at least ?

    this is the only one needed.

    Olivier.

    Friday, November 15, 2019 3:58 PM