"Internet Explorer Script Error" viewing .chm files


  • My problem happens with most (but not all) of my help files when invoked from a C++ utility. The error does not happen if I just double-click the .chm file in it's directory.

    The error message is :-

    Internet Explorer Script Error
    An error has occurred in the script on this page
    Line: 283
    Char: 5
    Error: Object doesn't support this property or method
    Code: 0
    URL ...
    Do you want to continue running scripts ont his page? (Yes/No)

    I tried unchecking the option "Disable script debugging (Internet Explorer)" , but it had no effect.

    I also tried unchecking the option "Disable script debugging (Other)".
    This causes a slightly different error :-

    "A Runtime error has occurred.
    Do you wish to Debug?
    Line: 282
    Error: Object doesn't support this property or method"


    I have been looking for a solution to this for some time.

    Another piece of online advice was to disable then re-enable ocx controls as follows, but it had no effect (NB I substituted my locations instead of winnt in the test below):-


    regsvr32 /u <drive>:\winnt\system32\hhctrl.ocx
    regsvr32 <drive>:\winnt\system32\hhctrl.ocx


    Another clue/red-herring is that some people get the error and others don't. (I work with a few other developers on the same application. There is no obvious pattern - the problem is seen on some Vista PCs and not others, and it is also seen on some XP PCs and not others).


    Sorry about the rambling nature of this message. I have temporarily implemented a workaround by modifying the code to call ShellExecute instaed of HTMLHelp. However, this loses the context-sensitive feature (the help utility now always opens at the first page, not on the relevant sub-page.)


    I am running IE7.


    Any help would be much appreciated, thanks..........Martin

    Monday, June 11, 2007 11:25 AM

All replies

  • I am experiencing exactly the same issue. It occurs in the Tax Wise 2009 help files that use RoboHelp or something like that. These files are displayed as context-sensitive bits in a reference panel.

    A javascript file withing the CHM has a call to some ActiveX on line 283 that seems to be the issue. Reinstalling .NET, downgrading from IE8 to IE7, reinstalling the app, etc did not fix it, although the message text changed slightly.
    Thursday, March 11, 2010 5:04 AM
  • Some ideas to try 

    <OBJECT id=hhctrlXX1 type="application/x-oleobject"

    For ActiveX Statements like this (above), delete the part that says 
    as this will run off to the internet and is not supported these days.


    Can I see how you are calling the help from VB?
    And what is at Line: 283 Char:5?  Can you show us please.

    Note: The error may come from a JS file that RH typically likes to includes in topic files.


    Rob Chandler http://Helpware.net
    Thursday, March 11, 2010 8:00 AM