none
Bing rest services not working in certain browsers RRS feed

  • Question

  • I am currently using the REST services in the Bings map AJAX V7 to create a route between destinations determined in my applications UI.

    In Internet explorer everything works properly and has no problems. However, it does not seem to making a call to the REST services when using firefox or crome.

    In IE it will add the pushpins and create a routeline between the destinations like it is suppose to, but when using firefox or crome it just shows a zoomed out map with nothing else displaying.

    Any reason why this is? And what steps are there that I can make to possibly fix this issue?

    Thanks,

    Shawn

    Tuesday, September 18, 2012 8:29 PM

Answers

  • You can also look at using the Directions Module without having to worry about messing around with the REST services: http://msdn.microsoft.com/en-us/library/hh312802.aspx

    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Wednesday, September 19, 2012 9:52 AM
    • Unproposed as answer by shaaaawn Wednesday, September 19, 2012 3:09 PM
    • Marked as answer by Ricky_Brundritt Monday, October 1, 2012 1:43 PM
    Wednesday, September 19, 2012 9:52 AM
  • It's hard to say what it causing this without seeing any code. I haven't come across this issue before. Also, if you are using Bing Maps internally you need to have an Enterprise license. If you do have one then you can contact the Bing Maps Enterprise support team who can look into this for you.

    http://rbrundritt.wordpress.com

    Thursday, September 20, 2012 8:37 AM

All replies

  • The first step would be posting the URL of your webpage so that we can help diagnose the problem...

    twitter: @alastaira blog: http://alastaira.wordpress.com/ | Pro Spatial with SQL Server 2012

    • Proposed as answer by Ricky_Brundritt Wednesday, September 19, 2012 9:52 AM
    • Unproposed as answer by shaaaawn Wednesday, September 19, 2012 3:09 PM
    Tuesday, September 18, 2012 9:26 PM
    Moderator
  • You can also look at using the Directions Module without having to worry about messing around with the REST services: http://msdn.microsoft.com/en-us/library/hh312802.aspx

    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Wednesday, September 19, 2012 9:52 AM
    • Unproposed as answer by shaaaawn Wednesday, September 19, 2012 3:09 PM
    • Marked as answer by Ricky_Brundritt Monday, October 1, 2012 1:43 PM
    Wednesday, September 19, 2012 9:52 AM
  • I can't really post a URL because it's a web application for the company I work for which requires a password.

    However, I do have an additional question which may be related to the issue.

    Whenever I first enter the page where my map is located I get the following javaScript error:

    "Unable to get value of the property 'getCredentials': object is null or unidentified"

    But this only happens the very first time I go to the map for the day.  After refreshing the page everything works fine and I have no issues with it.

    I just thought that was interesting and was wondering what might be the cause of this and if there is anything I could do to fix it?

    Wednesday, September 19, 2012 3:21 PM
  • Right now I don't really want to mess with the code that I have, but If I can't find a solution I will definitely look into it.

    Thanks

    Wednesday, September 19, 2012 3:23 PM
  • It's hard to say what it causing this without seeing any code. I haven't come across this issue before. Also, if you are using Bing Maps internally you need to have an Enterprise license. If you do have one then you can contact the Bing Maps Enterprise support team who can look into this for you.

    http://rbrundritt.wordpress.com

    Thursday, September 20, 2012 8:37 AM
  • I don't have an enterprise key but I have actually contacted the support team. They said they will contact me back in 24 hours or so.
    Thursday, September 20, 2012 2:59 PM