locked
How do I get IIS 7 to recognize that .net 4.5 is installed RRS feed

  • Question

  • User178896576 posted

    Hi,

    I've been going round and round with this for a couple of days now. I have a new 2008 r2 server with IIS 7 on it. I installed .net 4.5 onto it, and I would get errors trying to load an aspx. Error pages state the framework version as 2.0.xxxx. I have .net 4.0 selected in the app pool. I tried several app pools, everything. I discovered a test tool that determines if a .net version is installed or not. I tested it for 4.5 and the test came back successful. All this indicates that IIS 7 does not know to use the 4.5 version.

    How do I sett IIS 7 to use the 4.5 version of the .net framework?

    Thank you

    Thursday, April 11, 2013 9:11 PM

Answers

  • User-166373564 posted

    Hi nakins

    I think you need specify a .NET Framework Version for an Application Pool on IIS 7, you could follow the steps below,

    1.Open IIS Manager. For information about opening IIS Manager,

    2.On the Connections pane, expand the server node and click Application Pools.

    3.On the Application Pools page, select the application pool for which you want to specify a .NET Framework version, and then click Basic Settings in the Actions pane.

    4.In the Edit Application Pool dialog box, in the .NET Framework version list, select the version that you want the application pool to use or select No Managed Code if the application uses only native code.

    5.Click OK.

    Moreover, I think some tips are also available for you, the .NET 4.5 application pools are using .NET Framework 4.0 runtime. even though you have installed the .NET 4.5, It displays .NET Framework Version:4.0.30319,

    With regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 18, 2013 4:00 AM

All replies

  • User-1137493631 posted

    I hope apppool 4.0 will work for 4.5 versions, is there any specific error that you are seeing?

    Thursday, April 11, 2013 9:33 PM
  • User178896576 posted

    Thank you for your interest, but as I stated in my original post, the error pages are stating what the .Net framework is that is being used, and it is a 2.0 version and not a 4.0 version.

    Thursday, April 11, 2013 11:15 PM
  • User-166373564 posted

    Hi nakins

    I think you need specify a .NET Framework Version for an Application Pool on IIS 7, you could follow the steps below,

    1.Open IIS Manager. For information about opening IIS Manager,

    2.On the Connections pane, expand the server node and click Application Pools.

    3.On the Application Pools page, select the application pool for which you want to specify a .NET Framework version, and then click Basic Settings in the Actions pane.

    4.In the Edit Application Pool dialog box, in the .NET Framework version list, select the version that you want the application pool to use or select No Managed Code if the application uses only native code.

    5.Click OK.

    Moreover, I think some tips are also available for you, the .NET 4.5 application pools are using .NET Framework 4.0 runtime. even though you have installed the .NET 4.5, It displays .NET Framework Version:4.0.30319,

    With regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 18, 2013 4:00 AM