locked
This application has failed to start because the application configuration is incorrect ?????? RRS feed

  • Question

  • Hi

    I compile an application with VS2005 under windows 7. I have made some change to use OpenMP in my application. I finally removed OpenMP code ( I also remove openMP switch in project configuration) and I rebuild and run my application. The application do not want to start and give me this message.

    This application has failed to start because the application configuration is incorrect  .....

    If I change to from Debug to Release configuration it run perfectly. I clean all the debug configuration ( manually and automatically ) but the problem is still their.

     

    Friday, October 15, 2010 1:14 PM

Answers

  • Finally I reboot the machine for windows updates and all it is ok. I do not have explanation for that.
    • Marked as answer by Jesse Jiang Monday, October 18, 2010 8:06 AM
    Friday, October 15, 2010 5:41 PM

All replies

  • Are you trying to run the Debug version of the application on a different machine to the one on which you built it?  If so, it's probably because you haven't got the Debug version of the CRT library DLL installed on that machine.


    Answering policy: see profile.
    Friday, October 15, 2010 3:23 PM
  • I understand your point but the problem is not their. I have this error when I start the application directly by VS2005. If I start the application directly in VS2005 with the debug version I have the error message but if I do the same thing with the release, the application work perfectly. It is all the time on the development machine.
    Friday, October 15, 2010 3:45 PM
  • Are there any related events in the event viewer?
    Friday, October 15, 2010 4:31 PM
  • Finally I reboot the machine for windows updates and all it is ok. I do not have explanation for that.
    • Marked as answer by Jesse Jiang Monday, October 18, 2010 8:06 AM
    Friday, October 15, 2010 5:41 PM