none
App Service HTTP/2 Not Working RRS feed

  • Question

  • I have HTTP Version set to 2.0, but App Service is acting like it is not.

    I'm using https://tools.keycdn.com/http2-test to test and it says Negative! <site> does not support HTTP/2.0.

    Chrome is also using HTTP/1.1.

    It looks like this is affecting all apps in the App Service Plan. I have 2 currently and neither have working HTTP/2. I added a third and it doesn't support HTTP/2 either. I have HTTPS setup on both apps and my requests are using HTTPS.

    I've tried all sorts of combinations of changing the setting and restarting. I've tried stopping both apps and then restarting them.

    I also have a question open on StackOverflow: https://stackoverflow.com/questions/51332237/app-service-http-2-not-working#

    This seems to be only affecting new app services. I have older ones (from a month or so ago) that has http2 working just fine.
    • Edited by Nhitze Monday, July 16, 2018 4:41 PM
    Monday, July 16, 2018 4:24 PM

Answers

  • I reached out to Azure support. There was an issue with the server that my app service was hosted on that has been resolved.
    • Marked as answer by Nhitze Wednesday, July 18, 2018 8:57 PM
    Wednesday, July 18, 2018 8:57 PM

All replies

  • Hi Nhitze

    Thank you for your question. Could you try explicitly disabling and re-enabling it through Resource Explorer?

    1. Go to https://resources.azure.com/
    2. Make sure you are in Read/Write mode by clicking in the option to the left of your name.
    3. Find the affected site and browse to Config > Web: https://resources.azure.com/subscriptions/<yourSubscriptionId>/resourceGroups/<yourWebAppResourceGroup>/providers/Microsoft.Web/sites/<yourWebAppName>/config/web
    4. Change the property: "http20Enabled": from true to false by clicking in Edit properties, Update to “false” and then clicking PUT to save change.

    After disabling, verify that you're on HTTP 1.1 before re-enabling HTTP/2.0 and allow some time for changes to take effect.

    In case this may be something specific to your environment, do you have a support plan with your subscription?

    Tuesday, July 17, 2018 4:19 AM
    Moderator
  • You may also select the version through the Azure Portal: https://azure.microsoft.com/en-us/updates/http-2-configuration-now-available-in-the-azure-portal/

    Oded Dvoskin

    Tuesday, July 17, 2018 3:49 PM
    Moderator
  • That is the problem - I have it set, but my app never enables the HTTP 2 support. I've tried setting this property through the portal, resource explorer, and Azure CLI. None of them are working. The property says it is enabled, but the app does not behave like it is enabled.

    And yes, I've tried disabling/enabling it and waiting many times.

    • Edited by Nhitze Tuesday, July 17, 2018 6:30 PM
    Tuesday, July 17, 2018 6:29 PM
  • I would suggest opening a support ticket so the team can investigate.



    Oded Dvoskin

    Tuesday, July 17, 2018 7:11 PM
    Moderator
  • @Nhitze - As Oded suggested, could you open a support case for this issue? If your Azure contract doesn't carry support plan, please email us at azcommunity@microsoft.com with your subscription ID and URL to this thread as we're able to enable one-time support for you on this issue. We look forward to your reply.
    Tuesday, July 17, 2018 10:48 PM
    Moderator
  • I reached out to Azure support. There was an issue with the server that my app service was hosted on that has been resolved.
    • Marked as answer by Nhitze Wednesday, July 18, 2018 8:57 PM
    Wednesday, July 18, 2018 8:57 PM
  • Thanks for the update!

    Oded Dvoskin

    Wednesday, July 18, 2018 9:06 PM
    Moderator
  • It's great that this has been solved for Nhitze but I'm seeing the same thing on our Azure App Service. Not sure why we have to sign up for technical support service in order to raise a support request, considering this appears to be an issue with the service. 

    Any guidance on how we can get our service looked at?


    Nick Randolph ~ Built to Roam

    Friday, April 19, 2019 12:57 PM
  • @Nick Randolph - Do you mind opening a new MSDN forum post? We'll make sure this gets looked at through there. Feel free to drop my the link by email: oded.dvoskin@microsoft.com 

    Oded Dvoskin

    Friday, April 19, 2019 4:31 PM
    Moderator