none
U1073: NMAKE Fatal Error due to space in User Directory name

    Question

  • Severity Code Description Project File Line
    Error U1073 don't know how to make 'Name\Downloads\Python-3.4.3_\PCbuild\' python3dll D:\Users\<Username>\Downloads\Python-3.4.3_\PCbuild\NMAKE



    I am getting the following error in Visual Studio 2015 Community Edition due to having Visual Studio being unable to read my user path correctly. This makes no sense to me. I just finished talking to Office for Windows support, because they also do support for Visual Studio too, which also doesn't make sense to me. But, I digress. 


    I would like to know if there is a way to quote the Solution path somewhere in Visual Studio, as that is how you deal with a space in any path on Windows.

    Support just sent me to this page: https://msdn.microsoft.com/en-us/library/dd831853.aspx.


    I hope someone has an answer for how to fix this issue that Visual Studio shouldn't have... :(

    This is a Unix/Linux like problem! Being unable to read spaces in paths...



    Sunday, November 22, 2015 10:52 AM

Answers

  • Hi whitequill,

    We can check the path of $(SolutionDir) from right-click project -> Properties ->  Configuration Properties -> General -> Output Directory -> Edit. Then click the Macros button on right-button and you will see all macros' values as below image. But we can't modify any of them. Please try to add quotes in the Output Directory directly.

    According to the value of $(SolutionDir) in my side, it should support the spaces in the path. Please create a new C++ project to check whether other project also has this problem. If just for this specific project, please provide a sample project which can help us reproduce your problem. If for all projects, there may be something "wrong" with your Visual Studio. Please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as Administrator.
    2. Run Visual Studio 2015 in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Reset all settings through Tools -> Options -> Import and Export settings -> Reset all settings.
    4. Close all third part software, such as antivirus software.
    5. Try Repair Visual Studio 2015 in Control Panel -> Visual Studio 2015 -> Change -> Repair.

    Best Regards,
    Weiwei

    Monday, November 30, 2015 5:01 AM
    Moderator

All replies

  • Hi whitequill,

    Do you get this build error for VC++ app or others? Could you share us more detailed message? For example, what is the user path? Whether all projects have the same issue? 

    This document shared us the personal reasons and the methods to resolve the NMAKE Fatal Error U1073:

    https://msdn.microsoft.com/en-us/library/65faht2w.aspx

    To fix by using the following possible solutions

    1. Check the spelling of the target name.

    2. If targetname is a pseudotarget, specify it as a target in another description block.

    3. If targetname is a macro invocation, be sure it does not expand to a null string.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, November 25, 2015 12:01 PM
    Moderator
  • Yes, this is a VC++ app. I have not tried other app types. Cause I don't have code for other app types.

    This is my first time using Visual Studio. It could just be my lack of experience with Visual Studio seriously.

    When I see the way the error manifests it reminds me of the compiler having trouble reading past the 'space' in my user directory name. Is there a way I can check the target or pseudotarget in some menu?

    I just moved the Project directory to a path without any spaces and the error dose go away. I don't feel the error should be there at all though cause Windows frequently uses spaces in system directory names.





    Thursday, November 26, 2015 8:25 AM
  • Hi whitequill,

    >>Is there a way I can check the target or pseudotarget in some menu?

    We can view all files in solution through the Solution Explorer window. You can open this window from menu View -> Solution Explorer which is the first on in View menu.

    Then please select the project in Solution Explorer and click "Show All Files" in menu bar in top of Solution Explorer. All files which are contained or not contained in project will show in Solution Explorer. Then you can check all files in your solution.

    >>I don't feel the error should be there at all though cause Windows frequently uses spaces in system directory names.

    The File System may be do some processing for the directory name when it communicate with computer. And you also have proved that this error is caused by the spaces in the Project directory.

    >>I just moved the Project directory to a path without any spaces and the error dose go away.

    Thanks for sharing the solution here, please mark your reply as answer. It is benefit for other communities who has the same problem.

    Best Regards,
    Weiwei

    Thursday, November 26, 2015 9:26 AM
    Moderator
  • Thank you for your reply Weiwei,

    >>We can view all files in solution through the Solution Explorer window. You can open this window from menu View -> Solution Explorer which is the first on in View menu.

    I realized I asked the wrong question. I meant to ask if there way a way to put quotes around the solution directory path as is shown in the debug -> properties page, under Intermediate Directory $(SolutionDir)... Is there a place that I can check and edit what the $(SolutionDir) path is, to make sure that Visual Studio is reading it correctly?

    Also thank you very much for your other answers I will be sure to mark my reply as an answer, as it does solve the problem.

    I like to know the paths variables are pointed for debugging.



    Friday, November 27, 2015 10:21 AM
  • Hi whitequill,

    We can check the path of $(SolutionDir) from right-click project -> Properties ->  Configuration Properties -> General -> Output Directory -> Edit. Then click the Macros button on right-button and you will see all macros' values as below image. But we can't modify any of them. Please try to add quotes in the Output Directory directly.

    According to the value of $(SolutionDir) in my side, it should support the spaces in the path. Please create a new C++ project to check whether other project also has this problem. If just for this specific project, please provide a sample project which can help us reproduce your problem. If for all projects, there may be something "wrong" with your Visual Studio. Please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as Administrator.
    2. Run Visual Studio 2015 in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Reset all settings through Tools -> Options -> Import and Export settings -> Reset all settings.
    4. Close all third part software, such as antivirus software.
    5. Try Repair Visual Studio 2015 in Control Panel -> Visual Studio 2015 -> Change -> Repair.

    Best Regards,
    Weiwei

    Monday, November 30, 2015 5:01 AM
    Moderator