none
Edi receive message, UNA Issue. RRS feed

  • Question

  • Hi All,

    I have a scenario where a particular party is sending me an edifact message without the UNA segment.  

    I understand that the default value which I have given in the EDI disassembler pipeline will be taken into consideration. However they are sending QTY in decimal form'.' (QTY+47:549.300:KGM) whereas default value in Efact Delimiters  will be 0x3A, 0x2B, 0x2C, 0x3F, 0x20, 0x27....where 0X2C represents ','...If I change it to 0X2E which is decimal, it will accept the message and process but what if one more party sends a message without UNA and send QTY with ',' (QTY+47:549,300:KGM)...

    So I do not want to change the property of Efact delimiters , Is there any other option to acheive the same..I tried configuring in the specific party but I understand that BizTalk will only consider the above property.

    Kindly help if you have any idea ??

    Thanks,
    Varun


    Thanks, Varun

    Wednesday, March 18, 2015 7:23 PM

All replies

  •  Is there any other option to acheive the same..I tried configuring in the specific party but I understand that BizTalk will only consider the above property.

    I'm afraid we don't have other option to do that, you can also contact Microsoft support directly, perhaps they can help you with this problem.
    Tuesday, March 24, 2015 8:13 AM
  • You could make a custom pipeline component that prepends an una-segment only when you encounter the specific UNB from your sender party. Some easy string-manipulation on the incoming message will do. Other option might be to convert the qty-values in your map to the correct value. Hope this helps.
    Saturday, May 2, 2015 9:11 AM