locked
PHP requests and timeouts RRS feed

  • Question

  • User737701966 posted

    I have a website that I need to set low execution times for.  Some of the php pages on the site run for longer than 10 minutes and I'd like to have them timeout at 2 minutes.

    - I've set max_execution_time to 120 seconds via the php.ini, verified the setting took via phpinfo file I created.
    - set the CGI setting from 15 minutes to 2 minutes
    - set the "Request Timeout" setting under the FastCGI application settings for the PHP version I am running to 120 seconds

    Even after an IIS reset none of these settings seem to cause a request to timeout in with the values I've set. 

    Any tips? 

    Thanks!

    Friday, March 13, 2015 6:46 PM

All replies

  • User1183424175 posted

    Hi,

    I find the article say that This function has no effect when PHP is running in safe mode. There is no workaround other than turning off safe mode or changing the time limit    in the <var class="filename">php.ini</var>.

    For more information, please refer to the document:

    http://php.net/manual/en/function.set-time-limit.php

    Sunday, March 15, 2015 11:06 PM
  • User737701966 posted

    Hi

    We do not have PHP in safe mode so this definitely isn't the issue.

    Anything else we can look at?

    Monday, March 16, 2015 2:55 PM
  • User77253859 posted

    Don't forget the app pool settings as well

    You have 3 areas; PHP, FastCGI and IIS (app pool and site).

    Monday, May 4, 2015 7:29 PM