locked
Support of Workflow 3 on framework 3.5. RRS feed

  • Question

  • Hi All,

     We are working on an production hosted application whose crux is workflows (WF3)  running on framework 3.5  and we are using the following assemblies in the application.  

    • System.Workflow.Activities.dll
    • System.Workflow.ComponentModel.dll
    • System.Workflow.Runtime.dll

    As we know that the above assemblies are deprecated in 4.5  ,any idea whether Microsoft extends their support for the above dll's if I continue to run the existing workflows on current framework i.e FW 3.5.

    If yes, I think there is not other option other than migrating the workflows to FW 4 or 4.5 by changing the application framework to 4 or 4.5.. 

    Would be a great help if you to comment on this.

    Wednesday, March 5, 2014 9:06 AM

Answers

  • Hi,

    In my opinion, you can try migrating the application.  WF3 applications run on the .NET Framework 4 without modification and continue to be fully supported. For more information, you can refer here

    http://msdn.microsoft.com/library/ee264175.aspx

    #Windows Workflow Foundation (WF) Migration Guidance

    http://msdn.microsoft.com/en-us/library/ee264169(v=vs.110).aspx


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Pengzhen Song Monday, March 17, 2014 6:21 AM
    Thursday, March 6, 2014 3:04 AM

All replies

  • We are working on an production hosted application whose crux is workflows (WF3) running on framework 3.5 and we are using the following assemblies in the application.

    • System.Workflow.Activities.dll
    • System.Workflow.ComponentModel.dll
    • System.Workflow.Runtime.dll

    As we know that the above assemblies are deprecated in 4.5 ,any idea whether Microsoft extends their support for the above dll's if I continue to run the existing workflows on current framework i.e FW 3.5.

    If yes, I think there is not other option other than migrating the workflows to FW 4 or 4.5 by changing the application framework to 4 or 4.5..

    Would be a great help if you to comment on this.


    • Merged by Pengzhen Song Thursday, March 6, 2014 1:27 AM duplicate
    Wednesday, March 5, 2014 9:51 AM
  • Hi,

    In my opinion, you can try migrating the application.  WF3 applications run on the .NET Framework 4 without modification and continue to be fully supported. For more information, you can refer here

    http://msdn.microsoft.com/library/ee264175.aspx

    #Windows Workflow Foundation (WF) Migration Guidance

    http://msdn.microsoft.com/en-us/library/ee264169(v=vs.110).aspx


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Pengzhen Song Monday, March 17, 2014 6:21 AM
    Thursday, March 6, 2014 3:04 AM