none
VS2015 C++ global Executable Directories settings seem to be ignored when executing applications

    Question

  • I have just set up Visual Studio 2015, installed all the libraries I need and successfully built my C++ application.  When I attempt to run (debug) the application, Visual Studio tells me that it can't find the library DLLs that are in the folders that I specified in the VC++ Directories -> Executable Directories entry in global Microsoft.Cpp.Win32.user property page.

    If I copy the DLL's to the output folder, everything works, but for some reason, the Executable Directories paths don't seem to be added to the system PATH when executing my application.

    This all worked fine in VS2013.  Am I missing a setting somewhere or is this perhaps a bug in VS2015?

    Thanks.

    Saturday, July 16, 2016 1:03 AM

Answers

  • If I copy the DLL's to the output folder, everything works, but for some reason, the Executable Directories paths don't seem to be added to the system PATH when executing my application.

    I thought those settings were purely for the build, not for
    running/debug of your program.

    This all worked fine in VS2013.

    Are you sure? You hadn't perhaps done something else to accomplish the
    same result; such as setting the project's Debugging, Environment
    setting to modify the PATH environment variable?

    Dave

    • Marked as answer by _Greg__ Monday, July 18, 2016 6:10 PM
    Saturday, July 16, 2016 8:05 AM

All replies

  • If I copy the DLL's to the output folder, everything works, but for some reason, the Executable Directories paths don't seem to be added to the system PATH when executing my application.

    I thought those settings were purely for the build, not for
    running/debug of your program.

    This all worked fine in VS2013.

    Are you sure? You hadn't perhaps done something else to accomplish the
    same result; such as setting the project's Debugging, Environment
    setting to modify the PATH environment variable?

    Dave

    • Marked as answer by _Greg__ Monday, July 18, 2016 6:10 PM
    Saturday, July 16, 2016 8:05 AM
  • You are correct, the Executable Directories is for build.  I guess it is so long since I set it up that I forgot I had to manually add the directories to the PATH environment variable.

    Thanks,
    Greg

    Monday, July 18, 2016 6:10 PM