none
Remaning Schemas that was checked in to TFS RRS feed

  • Question

  • Hello All,

    I am running out in to an issue where I renamed the existing schema which was checked in previously. Now I cannot see the renamed schema in the Maps. It is referring to the old names everywhere like Orchestrations,Pipelines and Maps. And it is looking like this,

    I tried undo the Changes but its is not changing. I am stuck, can anybody please help me with this. Thanks in Advance



    • Edited by vdha Thursday, December 11, 2014 4:14 PM
    Thursday, December 11, 2014 3:57 PM

Answers

  • May be when you renamed the schema you have not renamed the TypeName. Go to the properties of the schema; change the TypeName property to TalentEmployeeExportHeader. Now see its referenced artifacts, it should reflect the TypeName.



    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    • Marked as answer by vdha Thursday, December 11, 2014 5:33 PM
    Thursday, December 11, 2014 5:04 PM

All replies

  • I understand that you have renamed the schema and you checked-In. Have you updated your map with the renamed schema and checked-In the updated map?

    If you have checked-in, it should there in TFS. If It’s not there means, I suspect you have not checked-in.

    Also when you update the schema, have you updated the other artifacts like maps, orchestration, pipeline with the updated schema reference and checked-in the artifacts?

    Check the history of the schema and the map you have checked-in. Does it show the change history of the updated check-In, if not then you don’t have the updated version in TFS.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.


    Thursday, December 11, 2014 4:37 PM
  • Ashwin,

    I havent checked anything in after I made the changes. The schema name was EmployeeExportHeader before and I changed it to TalentEmployeeExportHeader, now everywhere I am seeing EmployeeExportHeader and not TalentEmployeeExportHeader.

    For example in the Orchestration when I create message it is not showing the new name refers only to the old name. And in the pipeline with the FlatFileDisassembler, the HearderSchema it just shows the old name.

    It is not showing any error though when I build but concerned will it cause some issue in the future or when I chcek in.

    Thursday, December 11, 2014 4:47 PM
  • May be when you renamed the schema you have not renamed the TypeName. Go to the properties of the schema; change the TypeName property to TalentEmployeeExportHeader. Now see its referenced artifacts, it should reflect the TypeName.



    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    • Marked as answer by vdha Thursday, December 11, 2014 5:33 PM
    Thursday, December 11, 2014 5:04 PM
  • Ashwin,

    Can you tell me what to change when I rename name of Orchestration. There is no TypeName property for orchestration I deployed the project after renaming the Orchestration it shows the old name in console.

    Thanks

    Thursday, December 11, 2014 7:01 PM
  • Sorry, got it when I  click in the Process Area background of the Orchestration Design Surface.

    Thank you so much.


    • Edited by vdha Thursday, December 11, 2014 7:17 PM
    Thursday, December 11, 2014 7:17 PM