locked
Expression Blend is changing the HorizontalAlignment property RRS feed

  • Question

  • Expression Blend 4 is changing the HorizontalAlignment and or VerticalAlignment when moving TextBlock objects with the keyboard or mouse. For example, if I drag/move  a TextBlock with the mouse from the left side of the design area to the righ the HorizontalAlignment will change from "left" to "right". Can this be blocked? I don't want the HorizontalAlignmentto to change unless I manually change it.

    Thanks.

    Friday, July 9, 2010 6:26 PM

All replies

  • Unfortunately, the behavior of properties being set when you drag controls around in a Panel is not customizable.

    Thanks,
    Unni


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, July 9, 2010 8:49 PM
  • This is a big problem for me too. There is no way to set the HorizontalAlignment or VerticalAlignment. If I set them manually Blend doesn't adjust the margins, it moves the TextBlocks, and when I drag the TextBlocks back, it resets the HorizontalAlignment and VerticalAlignment, so I go round in circles.
    Monday, October 4, 2010 9:03 PM
  • Try adding next attribute in xaml to your TextBlock 'd:LayoutOverrides="HorizontalAlignment, VerticalAlignment"'. It worked for me. But here pops my question.
    Where does Blend store this data when i move object outside TopLeft section d:LayoutOverrides disapear. 
    Let me explain myself... I put object inside top,left and add parameter d:LayoutOverrides="...". Then i move object outside TopLeft to RightDown. I exit Blend. I start Blend and move this object to TopLeft and d:LayoutOverrides appears again. This is confusing for me since i thougth all data is saved inside xaml. Thats why im moving away from of Flashs FLA.
    Monday, April 4, 2011 5:33 AM
  • This is one of the most annoying "features" in Blend.  In the end, there's no way to get the layout to be the way you want, except to go and edit the Margins and Alignments by hand.  I could have done that with NotePad.

    Seriously, there needs to be an easy way to turn this off.  I like to set everything up with the alignments the way they should be, then do a quick resize of the design surface to see what moves where.  Invariably something I had anchored Left will suddenly be stretching, because I nudged its position a little bit and Blend put everything back the way it likes it.

    Tuesday, April 5, 2011 2:02 AM
  • This happens in Blend 3, too.  It was fine in another project I did, since I disabled resizing, but now that I'm trying to use a GridSplitter it is utterly annoying.  I thought these properties were supposed to be the new 'docking', yet they aren't working the way I want them too.  If I had paid full price for this, I would be fuming.

     

    But then again, Microsoft has been taking existent functionality away from Visual Studio, too. 

    Tuesday, August 23, 2011 5:41 PM