none
Problems Deploying VSTO Addin to Visio 2007 End-Computers RRS feed

  • Question

  • Hello,

    i am facing a problem and could not find a solution since 2 days, the situation is the following:

     

    We have developed a VSTO Solution for Visio 2010 (Visio 2007), for which i made a setup project for automatic deployment, meaning all needed files are copied to its destination locations (*.dll, *.manifest, *.vsto & help, doc and example files) and which does the necessary registry entries (LoadBehavior, Manifest, etc.). Everything works like it should under Visio 2010.

    Now we need to make also a deployment for Visio 2007. Therefore i have to make some changes in the addin itself (for example, changing from Ribbon GUI to traditional GUI and some other changes). Now, when i try to do a similar setup project (which we are making with an external software due to a huge number of deployable files and prerequisites checks) , go through the installation and try to start the Add-In (which should start automatically due to LoadBehavior = 3) the addin is not activated. I dont know why.

    So i started to find some solutions and tried the stuff with VSTO_SUPRESSDISPLAYALERTS and VSTO_LOGALERTS. Additionally i have everything in try/catch blocks during my Addin Load method, etc. So, Add-In does NOT load. I see no error messsages and there is no log file created also. When i go to the dialog in Visio 2007 where the addins show up it only says "not loaded". When i try to load it again though checking the box and say load i got an "The connected state of office add-ins registered in HKEY_LOCAL_MACHINE cannot be changed" error.

    Now, because i really have NO idea what i can try else, i have some additional, hopefully helpful thing i figured out:

    1. The Add-In does not load. However, when i close Visio 2007 and open the registry, the LoadBehavour is still on 3 and it hasnt change from 3 to 2 (like i would expect).

    2. My *.vsto file is copied to the application dir. Now, when i double click the vsto file, the click once procedure is starting (with this small dialog window telling that this addin is now installed) i got a "The Microsoft Office customization was successfully installed" message. When i start Visio 2007 i see that the addin is working now, which really confuses me. Now going to the addin menu i have 2 entries:

    a) one entry (active add_ins) with the successfully loaded addin through the click once installer telling me: "Place: file:///C:/Program Files/AppDir/AddinName.vsto" and

    b) one entry (inactive add_ins) with: "Place: C:\Program Files\AppDir\AddinName.vsto|vstolocal"

    The only thing which is different is the description part of the two entries.

    When i examine the registry after the successfully manually vsto deployment as described above, i seethe following two entrys:

    Registry entry after manually clicked *.vsto file:

    [HKEY_USERS\S-1-5-21-1752087698-3326290281-2267408603-1000\Software\Microsoft\Visio\Addins\AddinName]
    "Description"="AddinName Application VSTO AddIn for Visio 2007-2010"
    "FriendlyName"="AddinName"
    "LoadBehavior"=dword:00000003
    "Manifest"="file:///C:/Program Files/APPDIR/AddinName.vsto"


    Registry entry of my own setup project (working fine under Visio 2010):
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Visio\Addins\AddinName]
    "Description"="AddinName"
    "FriendlyName"="AddinName"
    "LoadBehavior"=dword:00000003
    "Manifest"="C:\\Program Files\\APPDIR\\AddinName.vsto|vstolocal"

     

    Does anybody have some idea what i can do to find the error i am doing wrong? (Oh, and excuse my english of course ,-),

    Thomas

     

    Update: What i tried now (as another workaround) is, i told my setup project to write the registry entries into HKEY_CURRENT_USER instead of HKEY_LOCAL_MACHINE. Now the addin works as expected. Unfortunaltey this is not a really solution for us, as most of our customers can not install the addin my themself. Normally there is an admin installing this addin on end computer and the addin should me available for all users on this machine and not only for the admin itself.


    Wednesday, June 15, 2011 6:56 AM

Answers

All replies