locked
SharePoint 2013 workflow option not showing RRS feed

  • Question

  • Hi,

    I have installed the workflow manager in a machine that is part of the SharePoint farm and registered the workflow with SharePoint.

    When going to /_admin/WorkflowServiceStatus.aspx it says workflow is connected, however when i go to sharepoint designer i dont have the option.

    I have installed the service packs and updates for sharepoint designer and have the farm on one of the latests patchs.

    How can i validate that my installation is correct?
    Wednesday, January 10, 2018 4:45 PM

Answers

  • Hi, 

    There may be many reasons for this issue, you can try below things for narrowing your issue:

    1. After installing workflow manager, we need to configure Workflow Manager to work with the SharePoint Server 2013 farm. Open the SharePoint Management Shell as an administrator and run the Register-SPWorkflowService cmdlet. There are four scenarios about the cmdlet, read the article and find the right Register-SPWorkflowService cmdlet that matches your circumstance.

    2. Whenever a new workflow service application proxy is created in SP2013, by default it will not be associated(service connection) with any web application. You can go to Central admin site > Manage web applications, select your web application > Service Connections, check if you have selected the "workflow service application proxy".


    3. Restart the WorkflowServiceBackend Service by following steps:

    a. Open a command prompt with administrator privileges

    b. Execute the following command: net stop WorkflowServiceBackend

    c. Execute the following command: net start WorkflowServiceBackend

    You can also refer to below article:

    http://techbrij.com/the-option-sharepoint-2013-workflow-platform-not-available 

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Thursday, January 11, 2018 2:17 PM

All replies

  • Have you checked if "App Management" and "Subscription settings" services, service applications and their proxies are provisioned and running on your SharePoint farm.

    References :

    Workflow Manager dependency


    Wednesday, January 10, 2018 6:06 PM
  • Hi, 

    There may be many reasons for this issue, you can try below things for narrowing your issue:

    1. After installing workflow manager, we need to configure Workflow Manager to work with the SharePoint Server 2013 farm. Open the SharePoint Management Shell as an administrator and run the Register-SPWorkflowService cmdlet. There are four scenarios about the cmdlet, read the article and find the right Register-SPWorkflowService cmdlet that matches your circumstance.

    2. Whenever a new workflow service application proxy is created in SP2013, by default it will not be associated(service connection) with any web application. You can go to Central admin site > Manage web applications, select your web application > Service Connections, check if you have selected the "workflow service application proxy".


    3. Restart the WorkflowServiceBackend Service by following steps:

    a. Open a command prompt with administrator privileges

    b. Execute the following command: net stop WorkflowServiceBackend

    c. Execute the following command: net start WorkflowServiceBackend

    You can also refer to below article:

    http://techbrij.com/the-option-sharepoint-2013-workflow-platform-not-available 

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Thursday, January 11, 2018 2:17 PM
  • Have you checked WFFArm status or SBFarm status?

    Get-SBFarmStatus and get-WFFARmstatus and check if everything sounds fine (Like services running ok).

    Thanks

    Sakthi.


    Sakthi Ganesh

    Thursday, January 11, 2018 4:51 PM
  • Hi,

    How are things going?

    If you think my suggestion is helpful, you could mark it as an answer. It will help others who meet the similar question in this forum.

    Thanks for your understanding!

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, January 18, 2018 9:05 AM
  • Hi,

    Sorry for the late response.

    Was missing the service connection on the web application due to have a custom group.

    I now see the option and I'm able to create and publish, however I'm not getting the result.

    Trying to debug the issue, for now seems like a network problem.

    Thx


    Rui Pais

    Monday, January 22, 2018 4:12 PM
  • Hi Allen,

    Your solution worked for me.

    Even after registerting the workflow service it did not show up 2013 workflow in the deisgn manager.

    When i have done stop and start of workflowbackend service it showed up.

    I have wasted 2 days to find this solution.

    Tuesday, May 22, 2018 5:52 AM