locked
xap not getting copied to clientbin RRS feed

  • Question

  • A VS2008 project I have has stopped copying newly compiled xaps to the clientbin of the website I'm developing. Some get copied, others don't. This started a couple of days ago. I've checked the SL projects attached to the website and they are all there (website properties>silverlight). I even removed and added one of the projects from/to the solution and the website properties and still no go.

    The only thing I can think of that happened in that same time period was that I moved and converted a solution to VS2010 RC on that same day.

    Saturday, March 20, 2010 7:47 AM

All replies

  • Hi snelldl,

     

    open the Project-Properties of your Web-Project go to the Silverlight-Applications-Tab. Are there all Silverlight-Applications added?

    Saturday, March 20, 2010 8:02 AM
  • Yes. As I stated in the original post, I tried re-adding one manually and it didn't make any difference.

    Monday, March 22, 2010 9:50 AM
  •  My environment is somewhat unusual, but it stopped copying the xap a long time ago.  What I do instead is just create a post build event on the silverlight project and issue a copy command to copy it from where it was built to the target clientbin folder.

    Sunday, March 28, 2010 12:00 PM
  • Is there any fix/workaround for this issue yet? 

    Tuesday, July 13, 2010 3:09 PM
  • I ended up switching over to VS2010 and called it good.

    Tuesday, July 13, 2010 3:20 PM
  • For me, this issue started after we switched to VS2010. 

    May be, there is some path resolving issue with VS2010 or may be we are missing something. 

    Wednesday, July 14, 2010 7:29 AM
  • I've never had the problem since I switched. Of course, I never had the problem with vs2008 on this solution for 3 months either. I guess the amount of time is about that long on vs2010 too.

    Wednesday, July 14, 2010 8:13 AM