locked
How to get Apple touch icons working for SharePoint site? RRS feed

  • Question

  • I'm trying to set up a shortcut to our company intranet from an Apple iPad and would like to have an icon set up. I have uploaded all appropriate icons to a library in my sharepoint site, and have entered the following code into the masterpage.<o:p></o:p>

    <link rel="apple-touch-icon" sizes="57x57" href="/SiteAssets/favicons/apple-touch-icon-57x57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="/SiteAssets/favicons/apple-touch-icon-114x114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="/SiteAssets/favicons/apple-touch-icon-72x72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="/SiteAssets/favicons/apple-touch-icon-144x144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="/SiteAssets/favicons/apple-touch-icon-60x60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/SiteAssets/favicons/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/SiteAssetsfavicons/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/SiteAssets/favicons/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="/SiteAssets/favicons/apple-touch-icon-180x180.png">
    <link rel="icon" type="image/png" href="/SiteAssets/favicons/favicon-192x192.png" sizes="192x192">
    <link rel="icon" type="image/png" href="/SiteAssets/favicons/favicon-160x160.png" sizes="160x160">
    <link rel="icon" type="image/png" href="/SiteAssets/favicons/favicon-96x96.png" sizes="96x96">
    <link rel="icon" type="image/png" href="/SiteAssets/favicons/favicon-16x16.png" sizes="16x16">
    <link rel="icon" type="image/png" href="/SiteAssets/favicons/favicon-32x32.png" sizes="32x32">
    <meta name="msapplication-TileColor" content="#ffffff">
    <meta name="msapplication-TileImage" content="/SiteAssets/favicons/mstile-144x144.png">

    <o:p>I have also tried changing the link here. But this didn't work either. I have already had a favicon setup here for a while working fine.
    <SharePoint:SPShortcutIconID="SPShortcutIcon1"runat="server"IconUrl="/SiteAssets/apple-touch-icon.png"/></o:p>

    Unfortunately it still isn't working and safari is just grabbing a screen grab of the site and using that as the image. What am I doing wrong, or is it not possible to do this with a sharepoint site? The same method worked perfectly on the company's public site which isn't sharepoint based.<o:p></o:p>

    Monday, December 1, 2014 10:36 PM

All replies

  • Just an update, I've just noticed that this seems to be working for my android phone and for iPhone. Looks to be just the iPad which is not functioning. Is there something different in the way the iPad works?
    Monday, December 1, 2014 10:49 PM