"The NTVDM CPU has encountered an illegal instruction" error message pops up when installing Visual SourceSafe 6


  • I keep receiving this error message "The NTVDM CPU has encountered an illegal instruction" when I try to install Visual SourceSafe 6.0.

    I couldn't find any information about how to fix this problem.

    All I can find on the Internet is "16 bit MS-DOS Subsystem MS-DOS Prompt - ntdetect The NTVDM CPU has encountered an illegal instruction." No more details.

    Anyone has an idea how to fix it?

    Friday, August 18, 2006 3:52 PM


All replies

  • Try the suggestions from this thread:


    It looks like in some cases this can be fixed by:

    - running SystemFileChecker (sfc.exe) or delete/re-extract the possibly corrupt ntvdm files

    - adding setver in config.nt

    - increase FILES number in config.nt (I remmeber there were some install failures related to this)

    - try http://support.microsoft.com/kb/q196453/

    - make sure you don't have a setup.com or something other similar trojan (see last post in http://www.techimo.com/forum/t146625.html) that gets executed before VSS installer



    Saturday, August 19, 2006 3:01 AM
  • Hello,


    I am getting a error as "16 bit MS-DOS Subsystem
    The NTVDM CPU has encountered an illegal instruction.
    CS:0dae IP:0105 OP:fe fe fe be fe Choose 'Close' to terminate the application" as soon as I login to windows.


    Please advise.



    • Proposed as answer by china man yms Saturday, August 28, 2010 1:57 AM
    Thursday, July 26, 2007 12:39 PM
  • I'd choose "Close"


    Your problem doesn't seem to have anything to do with source control or SourceSafe....

    Have you tried any of the suggestions from the previous post? Have you run an antivirus on your machine? What was the result?


    I'd use ProcessExplorer http://www.microsoft.com/technet/sysinternals/Utilities/ProcessExplorer.mspx and see what application launches that K18F11~1.Exe. Also, I'd use WindowsDefender ttp://www.microsoft.com/athome/security/spyware/software/default.mspx and look in Tools/SoftwareExplorer at the applications that are launched at startup, and remove the bad application or clean up your machine. That funky name of the executable sounds likely to be malware...


    You can search the net for other users hitting similar problems http://www.google.com/search?hl=en&q=Windows+login+The+NTVDM+CPU+has+encountered+an+illegal+instruction, and if none of those solutions apply, call Windows product support...



    • Proposed as answer by Scelo Monday, November 15, 2010 1:52 PM
    Thursday, July 26, 2007 8:37 PM
  • This looks strongly to be virus related.  I am getting a similar messge.  Last night AVG reported against one of the strange executables in %sysroot%\Windows\system32:

    Virus found win32/PolyCrypt

    More details later.

    Saturday, October 20, 2007 5:51 AM
  • I am getting this error on a newly formatted computer on Windows XP SP2. The error message along with other error dialogs pops up when Windows finished loading. It was caused when I installed a version of a language tool, Kingsoft PowerWord 2005. It also occurred when I unplugged my Sandisk USB Flash Drive.

    No comments on it now whether it is the cause of a virus or corrupted file but clearly, this problem is not caused by the user. Will check upon the frequency of this problem and see if uninstalling PowerWord fixes it.
    Thursday, November 29, 2007 10:56 PM
  • It also occurs when I set a shutdown shortcut 'shutdown -s -t 01'

    That is probably the main cause of an NTVDM error in my case.
    Friday, November 30, 2007 7:31 AM
  • Found the reason using AVG. It has nothing to do with using the shutdown command. It was caused by a Trojan found in a file named ODBCJET.EXE

    Caused when I was installing some final software programs from a removable flash drive to complete my reinstall of Windows XP SP2.

    Details Here:
    Sunday, December 02, 2007 9:07 AM
  • i have problem..

    I am getting a error as "16 bit MS-DOS Subsystem
    The NTVDM CPU has encountered an illegal instruction.
    CS:121e IP:0113 OP:ff ff ff d4 d0 Choose 'Close' to terminate the application" as soon as I login to windows.


    Please advise.


    Monday, January 26, 2009 12:01 PM
  • I had this same error occurring with a program I was using within my company. The problem turned out to be some edits in the Config.sys or config.nt file (they are the same, the extension depends on OS)  in the system32 folder. First, I would try increasing the number of files (mine is currently set at Files=255). If any changes have been made to this file it could very well be your problem. Just open it in notepad and take a look. Maybe something there could be the trouble.
    Thursday, February 04, 2010 2:39 PM
  • 应该是遇到非法的指令,企图修改系统内存的重要数据。可能是病毒或兼容问题造成的。
    Saturday, August 28, 2010 1:53 AM
  • Not the same but I had a problem wit the NTVDM-Hard Error.  It turned out to be very simple...one of the text data files that my exe used did not have a trailing CR/LF at the end.  the input statement could not get to the end of the file.

    Friday, October 15, 2010 2:59 PM