none
[help] vs2015 compile wxwidget3.1.0 errr

    Question

  • A clean download of wxWidgets-3.1.0

    then unzip, open the "wx_vc14.sln", choose release and x64, then failed.

    some errors like:

    Microsoft Visual Studio 14.0\VC\include\xtr1common(100): error C2399:
    Microsoft Visual Studio 14.0\VC\include\xtr1common(245): error C2399:
    Microsoft Visual Studio 14.0\VC\include\xtr1common(282): error C2399:
    Microsoft Visual Studio 14.0\VC\include\xtr1common(295): error C2399:

    and:

    Microsoft Visual Studio 14.0\VC\include\xtr1common(100): error C2399: ( ..\..\src\stc\scintilla\lexlib\CharacterCategory.cxx)
    Microsoft Visual Studio 14.0\VC\include\xtr1common(245): error C2399: ( ..\..\src\stc\scintilla\lexlib\CharacterCategory.cxx)
    Microsoft Visual Studio 14.0\VC\include\xtr1common(282): error C2399: ( ..\..\src\stc\scintilla\lexlib\CharacterCategory.cxx)
    Microsoft Visual Studio 14.0\VC\include\xtr1common(295): error C2399

    \Microsoft Visual Studio 14.0\VC\include\type_traits(1245): error C2061: 语法错误: 标识符“__make_integer_seq” (编译源文件 ..\..\src\stc\scintilla\src\AutoComplete.cxx)
    Microsoft Visual Studio 14.0\VC\include\type_traits(1249): error C2065: “_Vals”: 未声明的标识符 (编译源文件 ..\..\src\stc\scintilla\src\AutoComplete.cxx)
    Microsoft Visual Studio 14.0\VC\include\type_traits(1249): error C2975: “_Vals”:“std::integer_sequence”的模板参数无效,应为编译时常量表达式 (编译源文件 ..\..\src\stc\scintilla\src\AutoComplete.cxx)
    Microsoft Visual Studio 14.0\VC\include\type_traits(1190): note: 参见“_Vals”的声明 (编译源文件 ..\..\src\stc\scintilla\src\AutoComplete.cxx)
    Microsoft Visual Studio 14.0\VC\include\type_traits(1252): error C2061: 语法错误: 标识符“make_integer_sequence” (编译源文件 ..\..\src\stc\scintilla\src\AutoComplete.cxx)
    Microsoft Visual Studio 14.0\VC\include\type_traits(1261): error

    Wednesday, January 11, 2017 6:38 AM

All replies

  • Hi aowuaowu,

    Welcome to the MSDN forum.

    Where did you download the wxWidgets-3.1.0? I found the wxWidgets 3.1.0 can be downloaded from GitHub: https://github.com/wxWidgets/wxWidgets/releases/tag/v3.1.0 and scroll download to the bottom of this download page and click the wxWidgets-3.1.0.zip to download.

    Meanwhile, what’s your VS version? It is community, enterprise or professional?

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 12, 2017 9:01 AM
    Moderator
  • hi aowuaowu,

    Sorry to trouble you and does your issue is solved or not? If so, could you please share your solution and thank you for your sharing.

    If not, could you please provide the more detail information about your issue, that will help us to research your issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 16, 2017 8:46 AM
    Moderator