none
Configuring an Outgoing Batch in an agreement - Instance ID not coming back RRS feed

  • Question

  •  create a batch in an agreement, click on start, then do several refresh, I do not have an instance ID sent back as mentioned in  the documentation.

    I tried this on 2 different BTS 2010 and 2013, they are both 64 bit, one is win 2008 the 2nd is on a win 2012 R2

    Thanks for your help

    Wednesday, August 20, 2014 5:34 PM

Answers

All replies

  • In the BizTalk EDI Application, is the BatchControlMessageRecvLoc Receive Location Enabled?

    But...why are you looking for the InstanceID?  That's a dynamic value so you can't really use it anywhere.

    Wednesday, August 20, 2014 6:31 PM
  • I have enabled it but just right now, I noticed that it is in a disabled state. The error in the event log is :

    The receive location "BatchControlMessageRecvLoc" with URL "SQL://SQL2K12/BizTalkMgmtDb/" is shutting down. Details:"The receive adapter on this receive location is not supported on 64-bit host instances. Please make sure that the receive adapter is associated with a 32-bit only handler. ".

    I have not played with BTS EDI since version 2009, does this mean that all EDI functionality need to be run on a 32 bit host?

    I dont intend to use InstanceID anywhere, I am following lab 19 from MSDN BTS Training kit and it indicates that once we start the batch, 1 minute later we should refresh and InstanceID is displayed which is not hapopening on my box.

    The reason is that I am followed the lab 19 when testing the sample file on both machines I get the message suspended with the following error :

    The published message could not be routed because no subscribers were found. This error occurs if the subscribing orchestration or send port has not been enlisted, or if some of the message properties necessary for subscription evaluation have not been promoted. Please use the Biztalk Administration console to troubleshoot this failure.

    Wednesday, August 20, 2014 7:01 PM
  • I created a 32bit only receive host and it worked fine
    Wednesday, August 20, 2014 7:16 PM
  • Yes, the legacy SQL Adapter is not supported in 64-bit hosts.
    • Marked as answer by Angie Xu Tuesday, August 26, 2014 1:07 AM
    Wednesday, August 20, 2014 7:19 PM