locked
Data Factory V2 Error "errorCode": "2200", "message": "Failure happened on 'Sink' side. RRS feed

  • Question

  • Im using the following as a workshop

    https://www.youtube.com/watch?v=IAqJ6nCDtGc

    I have some sales data in an Azure SQL Database (Rather than an on premise database)

    And I have a data lake

    Ive successfully set up the Connectors and Data sets

    Ive created the pipeline with a copy activity as per the above video

    When I run it I get the following

    { "errorCode": "2200", "message": "Failure happened on 'Sink' side. ErrorCode=UserErrorFailedFileOperation,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=The request to 'Unknown' failed and the status code is 'BadRequest', request id is ''. <!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01//EN\"\"http://www.w3.org/TR/html4/strict.dtd\">\r\n<HTML><HEAD><TITLE>Bad Request</TITLE>\r\n<META HTTP-EQUIV=\"Content-Type\" Content=\"text/html; charset=us-ascii\"></HEAD>\r\n<BODY><h2>Bad Request - Invalid URL</h2>\r\n<hr><p>HTTP Error 400. The request URL is invalid.</p>\r\n</BODY></HTML>\r\n ,Source=Microsoft.DataTransfer.ClientLibrary,''Type=System.Net.WebException,Message=The remote server returned an error: (400) Bad Request.,Source=System,'", "failureType": "UserError", "target": "Copy Sales data to data lake" }

    This is the first error I havent been able to decipher, Any help would be really appreciated.

    Debbie


    Debbie

    Wednesday, December 12, 2018 4:58 PM

All replies

  • Hi Debbie,

    Did you try the 'Test connection' button on your ADL linked service?  There is an invalid URL reference in the error you posted, and the only URL I can think of on the sink side is the ADL URL which looks like this:

     "dataLakeStoreUri": "https://<account_name>.azuredatalakestore.net/webhdfs/v1",
    The linked service will still be able to be created even if the URL is malformed, but the 'Test connection' should not succeed.  You can view the URL in your linked service by looking at its JSON configuration code.


    Thursday, December 13, 2018 12:22 AM
  • All my Test connections are successful

    IS there anything else I can do to check? I've gone into the Data Lake Store Gen 1 Connector to check the URL and it seems correct to me. Its taking the form of the one above and it has the correct account name

    Could it possibly be the URL I have used when creating an App registration? I didnt know what to use as the URL Here so I just used our companies url


    Debbie



    Thursday, December 13, 2018 9:08 AM
  • Hi Debbie,

    Would you be able to edit your linked service and share that snapshot of that window? 

    Nirmal


    nirmal

    Monday, December 17, 2018 12:31 PM
  • I found out what the issue was. 

    I had set up a dynamic file path for the data Lake so the file would be placed into Year/Month/Day folders but this had caused the above issue. Once I deleted this path and just ran it into the data lake it worked.

    The file path I used was from this u-tube how to guide

    uhttps://www.youtube.com/watch?v=IAqJ6nCDtGc

    I still need to figure out how to do the above but at the least I can get my file into the data lake


    Debbie

    Wednesday, December 19, 2018 1:12 PM