Application problem in Session 0 RRS feed

  • Question

  • hi!

    I have a problem with my app, started in thread, which started from service in 0 session.  

    Don't know of which theme this question - administrating win 2008 or development...

    More information

    I have a service, which started automatically on system start. It's worked under domain account at session 0. 

    by schedule service start another application via COM (app2). Application work fine, but only in single thread. If I try to start another copy of app2 from this service - it's don't work and closed with errors. 

    BUT, if i'm starting this code (which worked at service and starts app) under my server or  domain account (not  0 session), app2 works fine in several threads and there is no errors...

    I were trying to set interactive mode for my service - not solved problem.

    And questions:

    1. is this problem of session 0 isolation?

    2. Is there any solution of these problem?

    3. Can i start service not at session 0?

    Monday, November 21, 2011 6:58 PM