locked
Email not sent from workflow RRS feed

  • Question

  • I have created InfoPath form and published the same in Form library.

    I have linked the same to a workflow using Sharepoint designer.

    The workflow is having simple task to send e-mail to the specified person.

    After approving the form the workflow status is "Completed" but any mail is not being sent to the mentioned person.

    Do i need to activate any service for this?

    Do i have to configure anything in central administration?

    Wednesday, July 25, 2012 11:07 AM

All replies

  • Hi,

    Just try to run below command and check

    stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true
    Let us know your result


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"

    Wednesday, July 25, 2012 11:58 AM
    Moderator
  • Hi,

    Can you please let me know that You are using SharePoint default SendEmail activity or using .Net API. If you are using SharePoint SendEmail activity, please make sure outgoing email setting is configure in "Central Admin" site.

    To configure outgoing email settings please refer http://technet.microsoft.com/en-us/library/cc263462%28v=office.12%29.aspx link.

    It may be possible some error is occurred during send email. For more information about exact error please check 12-hive SharePoint error log in Log folder and window event log.

    • Marked as answer by OOB Friday, July 27, 2012 10:46 AM
    • Unmarked as answer by OOB Friday, July 27, 2012 10:46 AM
    Thursday, July 26, 2012 4:06 AM
  • @Hemandra :

    Access denied

    Friday, July 27, 2012 10:45 AM
  • Right click on your cmd line and click run as administrator. then you need to use above command.

    Also make sure that you are using admin account.


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"

    Friday, July 27, 2012 10:54 AM
    Moderator
  • I am Still facing this issue....? Can you propose an order answer? Thanks 
    Wednesday, October 31, 2012 11:52 AM