locked
SDK 7.0 apps won't run in Simulator 6.1 RRS feed

  • Question

  • User21137 posted

    I'm using Xamarin.iOS 7.0 and Xcode 5.0 with the 6.1 simulator installed.

    When I create a new Solution with just an iOS project inside. (The Utility app for example.) I can't get it to run in the iOS 6.1 simulator. The simulator starts as you'd expect, but the log says the following:

    Starting iOS simulator 6.1
    Launching application
    Application launched. PID = 18124
    
    Application Terminated
    

    A breakpoint in the Main method of Application also won't trigger. Running the same application in the iOS 7.0 simulator triggers the breakpoint and runs fine otherwise. I've set the Deployment target to 6.0 in the Info.plist.

    I'm quite new to Xamarin and native development for iOS so probably I'm just missing something obvious, but applications built with Titanium and Xcode 5 run fine in the same 6.1 simulator for example.

    Friday, September 20, 2013 12:49 PM

All replies

  • User21137 posted

    Using Release deployment I'm able to get an error message:

    Dyld Error Message:
      Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    

    I just noticed the build also runs fine on an actual device running iOS 6.1.4, so this might be a bug in the iOS 6.1 simulator, but it's still pretty annoying. Nobody familiar with this?

    Friday, September 20, 2013 2:17 PM
  • User2589 posted

    Could you be using a beta version of OSX 10.9 (Mavericks) ?

    Such issues are always hard to diagnose (or reproduce) withour the version information of all products you are using.

    The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).

    Friday, September 20, 2013 5:28 PM
  • User2473 posted

    I am also having this problem. I just ran the upgrade for Xamarin and Xcode yesterday. I have the 7.0, 6.1, and 6.0 simulators installed.

    I can only run my application with the 7.0 simulator. I did not participate in the beta program for iOS 7 so all the software I have is the latest release.

    I have sent a crash report to priority support.

    Friday, September 20, 2013 6:50 PM
  • User16703 posted

    I have the same problem Since yesterday after upgrading xamarin studio and Xcode with Ios SDK 7.

    My app is working on ios7 simulator but the control alignments are completely messed up. The app is no longer working with simulator 6.1 to older versions of iOS.

    The Application Output log is :


    Starting IOS simulator 6.0 Launching application Application lauched PID=330

    Application Terminated.

    FYI: I already tried reset content of simulator.Please Help asap.

    Here is complete information about xamarin studio log === Xamarin Studio ===

    Version 4.0.12 (build 3) Installation UUID: c3a6d4b3-6136-47d2-a298-690103364c49 Runtime: Mono 3.2.3 ((no/8d3b4b7) GTK 2.24.20 GTK# (2.12.0.0) Package version: 302030000

    === Apple Developer Tools ===

    Xcode 5.0 (3332.25) Build 5A1413

    === Xamarin.Mac ===

    Xamarin.Mac: Not Installed

    === Xamarin.Android ===

    Version: 4.8.1 (Starter Edition) Android SDK: /Users/**/Library/Developer/Xamarin/android-sdk-macx86 Supported Android versions: 2.1 (API level 7) 2.2 (API level 8) 2.3 (API level 10) 3.1 (API level 12) 4.0 (API level 14) 4.0.3 (API level 15) Java SDK: /usr java version "1.6.051" Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509) Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

    === Xamarin.iOS ===

    Version: 7.0.0.11 (Indie Edition) Hash: aa35ba3 Branch: Build date: 2013-18-09 16:42:48-0400

    === Build Information ===

    Release ID: 400120003 Git revision: 593d7acb1cb78ceeeb482d5133cf1fe514467e39 Build date: 2013-08-07 20:30:53+0000 Xamarin addins: 25a0858b281923e666b09259ad4746b774e0a873

    === Operating System ===

    Mac OS X 10.8.5 Darwin kXXX-XXX.*.com 12.5.0 Darwin Kernel Version 12.5.0 Mon Jul 29 16:33:49 PDT 2013 root:xnu-2050.48.11~1/RELEASEX8664 x86_64

    Friday, September 20, 2013 7:59 PM
  • User2473 posted

    Here is the bug report:

    https://bugzilla.xamarin.com/show_bug.cgi?id=14891

    Friday, September 20, 2013 8:07 PM
  • User20098 posted

    This also occurred in my project,

    and I try to make new project and move all of my setting to new project, it also raise same error.

    Just for an idea,

    I use many components in my project.

    Isn't this causes components which built in SDK 6.1?

    I use,

    Google Maps 1.4.3

    SQLite.Net 1.0.1

    ZipArchive 1.0

    JSON.Net 4.5.11

    BTProgressHUD 1.7

    SimpleStorage 1.1

    P.S.

    Sorry, I misunderstanding @Qonstrukt 's first report.

    He made new project, but same error occurred.

    Saturday, September 21, 2013 12:07 AM
  • User8866 posted

    Not even Xamarin's Tasky sample app runs in iOS 6 simulator. So doubt it is something specific we're doing.

    Saturday, September 21, 2013 7:04 AM
  • User21137 posted

    @poupou, I'm indeed running the latest Mavericks DP, but looking at @IsaacEckert's bug report, he's facing the exact same error with Mountain Lion.

    When I opened the topic I was running Ximian Studio 4.1 alpha, but I've downgraded to 4.0 since then and threw away all my settings and still face the problem, so that too shouldn't be the culprit.

    Saturday, September 21, 2013 10:50 AM
  • User16703 posted

    @poupou

    Can you please reply to question?

    Tuesday, September 24, 2013 2:42 PM
  • User2589 posted

    he's facing the exact same error

    @Qonstrukt it's not the exact same error. They are both runtime link errors - but the reasons are different.

    The one from Mavericks happens between Apple supplied libraries. The one from the bug report comes from user code (which seems to be missing some C++ symbols).

    For the Mavericks issue it is possible to workaround the issue by enabling the linker (Link SDK) on your simulator builds. That will remove unused code that triggers the link error (but your builds will be a bit slower).

    Tuesday, September 24, 2013 3:32 PM
  • User21137 posted

    I'm sorry, you're absolutely right. I checked his bug report on my phone lastly and must've flicked through it a bit too quickly. Enabling the linker helped making my app run in the iOS 6.1 simulator, so thanks a lot!

    Is this an error on Apple's side, or is this something Xamarin can fix? As I understand this might hinder debugging a bit. So it would be great if I could still disable linking. :)

    Tuesday, September 24, 2013 5:58 PM
  • User2473 posted

    Adding '-cxx' the the mtouch options under iOS Build fixed my issue.

    Thank you for your help.

    Tuesday, September 24, 2013 7:36 PM
  • User21137 posted

    That doesn't unfortunately work for me. Enabling SDK linking seems to be the only thing that does.

    Tuesday, September 24, 2013 8:36 PM
  • User14255 posted

    I have same problem after update to mac osx maverick

    Saturday, October 12, 2013 4:01 PM
  • User23279 posted

    I have same problem after update to mac osx maverick.

    You should check Link SDK in your projects options.

    Friday, October 25, 2013 6:43 AM
  • User205 posted

    Thanks, the "Link SDK" thing made it work for me too ;-)

    Friday, October 25, 2013 8:13 AM
  • User189 posted

    Same issue here on 10.9, using alpha stream of Xamarin.iOS (7.0.3.213) and Xamarin Studio (4.1.12, build 6). Enabling linking of SDK assemblies only seems to do the trick for me.

    Oddly enough I can't run a release build on my device (iPhone5, 7.0.3) unless select to not link anything.

    Friday, October 25, 2013 8:17 AM
  • User21137 posted

    Yeah, I'm having the same issue. Not able to run a release version, except when not linking. The app immediately crashes after the splash screen disappears. So this makes testing on the iOS 6.1 Simulator and iOS 7.0 devices at the same time increasingly difficult.

    Friday, October 25, 2013 8:42 AM
  • User25930 posted

    Now it's worked when updated on Alpha version, resolved on my problem.

    details on updated: - Xamarin Studio 4.1.12 - Xamarin.Android 4.10.0 - Xamarin.iOS 7.0.3

    Saturday, October 26, 2013 4:53 AM
  • User2788 posted

    same problem here..

    OSX Mavericks GM

    Xamarin Studio Version 4.0.13 (build 38)

    Xamarin.iOS Version: 7.0.2.7

    Thanks for the "Link SDK" workaround..

    Friday, November 1, 2013 5:40 PM
  • User189 posted

    To add more to this issue I have found that using UrbanAirship, SDWebImage or GoogleAnalytics bindings found on the monotouch-bindings github will cause the same issue. I am able to use Newtonsoft.Json.dll just fine, but it is not a binded dll, just normal .NET dll.

    Monday, November 4, 2013 1:46 AM
  • User189 posted

    I should clarify, the binding DLL's were made on ML, even when I remake them in Mavericks it does not change anything.

    Monday, November 4, 2013 3:21 AM
  • User5797 posted

    I am running 7.0.4 with the same issue. The only thing that worked for me was the -cxx build options. I am using the GM build of Mavericks.

    EDIT: I may have spoke too soon. It appears when I "clean" after switching ios simulator version, the issues appears again.

    Wednesday, November 6, 2013 5:23 AM
  • User27162 posted

    Linking SDKs fixed this for me, thanks!

    Thursday, November 7, 2013 11:37 AM
  • User27883 posted

    I had the same issue and Linking SDK's also fixed my problem, but what does Linking SDK does? Do I get any other side effect if I enable that?

    Hope Xamarin can fixed that from source. Thanks a lot

    Saturday, November 9, 2013 1:58 PM
  • User189 posted

    The warning the Xamarin Studio dialog says is that you may not be able to debug certain parts of the app.

    Tuesday, November 12, 2013 2:32 AM
  • User53366 posted

    Had similar issue after upgrading to Xamarin Studio 5.4 and iOS Simulator 8.0, i.e. could run on iOS 8.0 simulator but not iOS 7.0. Setting linker option "Link SDK assemblies only" seems to solve the issue.

    Monday, September 22, 2014 9:35 PM