locked
.TMP files all over the place in VS 2015 RRS feed

  • Question

  • User147941623 posted

    I'm editing HTML files on an FTP mounted drive with Webdrive under Windows 10.  Visual Studio Community 2015 Update 2 leaves a bunch of .TMP files I've been working on.  For example: somepath\config.php~RF786cba4.TMP

    How do I stop this?    I have AutoRecover completely off.

    Wednesday, April 13, 2016 3:59 AM

Answers

  • User-166373564 posted

    Hi kenw,

     All these files I change on my FTP server (now a mapped drive) have .TMP file equivalent's.  I need that to stop.  Its ridiculous.    Heres a site I'm done with but Visual Studio leaves this garbage:

    For auto-saved files, they are related to temporary files or  AutoRecover feature.

    As I know, we use Visual Studio’s AutoRecover feature to recover work. I think we can disable AutoRecover to stop suto-saved files, go to Tools > Options > Environment > AutoRecover and uncheck Save AutoRecovery information.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 22, 2016 8:29 AM

All replies

  • User-166373564 posted

    Hi kenw,

    How do I stop this?    I have AutoRecover completely off.

    As you create and run ASP.NET applications from Visual Studio, temporary files are placed into the <sysdrive>:\Windows\Microsoft.NET\Framework[64]\<vernum>\Temporary ASP.NET Files folder. The folders and files under this folder can be removed with no harm to your development computer. Do not remove the "Temporary ASP.NET Files" folder itself, just the folders underneath this folder. If you use IIS for ASP.NET development, you may need to run the iisreset.exe utility from the command prompt prior to deleting any files/folder under this folder. IIS will sometimes keep files in use in this folder and iisreset will release the locks so the files/folders can be deleted.

    Hope it helps.

    Regards,

    Angie

    Wednesday, April 13, 2016 9:28 AM
  • User147941623 posted

    This is not my problem.  I don't care about temp files in \Windows\Microsoft.NET\Framework[64]\<vernum>\Temporary ASP.NET.  Visual Studio is creating .TMP files in my source code tree and leaving them there.  I map a drive letter to an FTP server and edit files over that.  All these files I change on my FTP server (now a mapped drive) have .TMP file equivalent's.  I need that to stop.  Its ridiculous.    Heres a site I'm done with but Visual Studio leaves this garbage:

    ./wp-content/themes/jupiter/framework/functions/general-functions.php~RF7d8b927.TMP
    ./wp-content/themes/jupiter/framework/functions/general-functions.php~RF7c711be.TMP
    ./wp-content/themes/jupiter/framework/includes/bfi_thumb.php~RF7ddfd0e.TMP
    ./wp-content/themes/jupiter/components/shortcodes/mk_portfolio/config.php~RF786cba4.TMP
    ./wp-content/themes/jupiter/components/shortcodes/mk_portfolio/loop-styles/classic.php~RF7c2471f.TMP
    ./wp-content/themes/jupiter/components/shortcodes/mk_portfolio/mk_portfolio.php~RF7856f31.TMP

    Wednesday, April 13, 2016 8:08 PM
  • User-166373564 posted

    Hi kenw,

     All these files I change on my FTP server (now a mapped drive) have .TMP file equivalent's.  I need that to stop.  Its ridiculous.    Heres a site I'm done with but Visual Studio leaves this garbage:

    For auto-saved files, they are related to temporary files or  AutoRecover feature.

    As I know, we use Visual Studio’s AutoRecover feature to recover work. I think we can disable AutoRecover to stop suto-saved files, go to Tools > Options > Environment > AutoRecover and uncheck Save AutoRecovery information.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 22, 2016 8:29 AM