locked
Cannot filter view by using Assigned To RRS feed

  • Question

  • Hi,

    I customized a view (converted to data view, added some additional data sources and used some xsl) a while ago but I didn't realized until now that I cannot filter the view by selecting Assigned To in the column header. The view has about 20 columns and all the other filters works as they should.

    Image of the error:

     

    The text under the orange/yellow color is the name of the site and when I check the HTML for the filter it looks something like:

    <nobr><span><A HREF="/site/_layouts/userdisp.aspx?ID=4">John Doe</A><img border="0" height="1" width="3" src="/_layouts/images/blank.gif"/><a href='javascript:' onclick='IMNImageOnClick();return false;' class='ms-imnlink'><img name='imnmark' title='' border='0' height='12' width='12' src='/_layouts/images/blank.gif' alt='No presence information' sip='john@dough.com.au' id='imn_13516,type=sip'/></a></span></nobr>

    for each user, so it looks like everything from <nobr> to </nobr> is displayed and not only the name. I can sort by using ascending and descending

     

    I guess the question is too generic and do not provide enough details but I'm hoping someone else has experienced the same issue and have a solution.

    Please let me know if you have any questions.

     

    Thanks in advance.

    Tuesday, August 16, 2011 2:24 AM

All replies

  • Kindly provide your xslt so that i can suggest wehere you have gone wrong
    Best Regards, Ashutosh | SharePoint World
    Tuesday, August 16, 2011 10:17 AM
  • Hi triple9,

     

    I am having the same problem with some custom data views I created with joined data sources.  Let me know if you found an answer please.  I have seen this same question in several places but no resolution.

     

    Thanks

     

    Angel

    Thursday, October 27, 2011 9:08 PM