locked
Issue with installing Entity Framework RRS feed

  • Question

  • User-1140083708 posted

    Hi,

    I just created a new project and tried to install EntityFramework but I am getting the following error. I am using VS2013 Pro.

    Any help would be appreciated.

     

    PM> Install-Package EntityFramework

    Install-Package : The remote server returned an error: (403) Forbidden.

    At line:1 char:16

    + Install-Package <<<< EntityFramework

    + CategoryInfo : NotSpecified: (:) [Install-Package], WebException

    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    Wednesday, July 22, 2015 5:31 PM

All replies

  • User2024324573 posted

    Seems to be connection error to the nuget package source.

    Could you please check the package sources are ok: Tools->Options->NuGet Package Manager->Package Sources

    I am using VS 2013 Community Edition and it installs EF successfully.

    Also I can install EF from Options->Nuget Package Manager->Manage NuGet Packages for Solutions..

     

    Hope this will help.

     

     

     

    Wednesday, July 22, 2015 5:48 PM
  • User61956409 posted

    Hi Dave22,

    You could try to clear Package Cache then install it again. Or you could search and install Entity Framework from Manage NuGet Packages window.

    Best Regards,

    Fei Han

    Thursday, July 23, 2015 4:17 AM
  • User-1140083708 posted

    Hi Fei,

    Thanks for your help. I tried to install it from Manage Nuget Packages window but I still got the same error (The remote server returned error: (403) Forbidden)

    Dave

    Thursday, July 23, 2015 10:05 AM
  • User-1140083708 posted

    Hi mostafasydne,

    Thank you so much for your help. I checked the package sources as you said. I am not able to see your screenshots but I have the following:

    Available package sources: https://www.nuget.org/api/v2/

    Machine-wide package sources: https://www.nuget.org/api/v2/curated-feeds/microsoftdotnet/

    I also tried to install using Manage Nuget Packages but got the same error.

    Dave

    Thursday, July 23, 2015 10:19 AM
  • User-1140083708 posted

    I uninstall and reinstall Nuget Package and now when I try to install EntityFramework I get this error:

    PM> Install-Package EntityFramework

    The source at nuget.org [https://www.nuget.org/api/v2/] is unreachable. Falling back to NuGet Local Cache at C:\Users\419282.BA.002\AppData\Local\NuGet\Cache

    Install-Package : Unable to read package from path 'EntityFramework.6.1.3.nupkg'.

    At line:1 char:16

    + Install-Package <<<< EntityFramework

    + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidDataException

    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    Thursday, July 23, 2015 5:10 PM
  • User2024324573 posted

    Nothing I can see except the connection issue with the server.

    Can you use NuGut for other package installation, please try some other packages and whether the same issue happen or not.

     

     

    Thursday, July 23, 2015 6:19 PM
  • User-1140083708 posted

    Hi Mostafa,

    I tried to install some other packages and got the same error.

    Thanks you.

    Dave

    Friday, July 24, 2015 10:31 AM
  • User-1926401737 posted

    Hi Dave,

    Your problem is related installing packages in Visual Studio failed, you could post the problem in Visual Studio forum for help.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?category=visualstudio%2Cvsarch%2Cvsdbg%2Cvstest%2Cvstfs%2Cvsdata%2Cvsappdev%2Cvisualbasic%2Cvisualcsharp%2Cvisualc

    With Regards,

    swing

    Wednesday, July 29, 2015 4:45 AM
  • User-1140083708 posted

    Thank you for your suggestion. I'll post this issue there as you said.

    Dave

    Wednesday, July 29, 2015 8:30 AM