none
WDK 10 and Visual Studio 2015 acting funny RRS feed

  • Question

  • I installed WDK 10 on my computer, and I tried to build a simple driver (code posted below) and I got the error : An SDK corresponding to WDK version '8.1' was not found.Please install the SDK before building. I downloaded and installed the Windows 10 SDK, and then tried build again, this time I was getting multiple syntax errors, the following code :

    extern "C" {
    #include <ntddk.h>
    #include <ntdddisk.h>
    #include <wdf.h>
    #ifdef ALLOC_PRAGMA
    #pragma alloc_text(INIT, DriverEntry)
    #endif
    	NTSTATUS DriverEntry(IN PDRIVER_OBJECT DriverObject, IN PUNICODE_STRING RegistryPath) {
    
    	}
    }

    Shows the following errors: fatal error C1083: Cannot open include file: 'ntddk.h': No such file or directory, and multiple intellisense errors.

    How do I fix this?

    I'm using Windows 8.1, VS 2015


    • Edited by NabeelOmer Sunday, March 6, 2016 1:25 PM
    Sunday, March 6, 2016 10:29 AM

All replies

  • Sorry? To build what?

    Does *it* build, if you change the target to Win10?

    -- pa

    • Edited by Pavel A Sunday, March 6, 2016 11:13 AM
    Sunday, March 6, 2016 11:09 AM
  • Besides the question of whether it builds when targeted to Windows 10, was this a Windows 8 WDK/VS2013 project you upgraded?


    Don Burn Windows Driver Consulting Website: http://www.windrvr.com

    Sunday, March 6, 2016 12:39 PM
  • I apologize, I have corrected the question. No it doesn't.
    Sunday, March 6, 2016 1:27 PM
  • No, it is not.
    Sunday, March 6, 2016 10:46 PM
  • I had the same issue("ntddk missing" error. I changed the target platform to 10.0.102.40.0. Earlier it was 10.0.10586.0.
     I am not sure about this dependency as to why the ntddk  file will be overlooked in the second version. The issue does not occur in the first version(10.0.102.40.0.)
    Monday, March 14, 2016 9:34 AM