none
Resource Departments custom field not showing up RRS feed

  • Question

  • Recently upgraded to Project Server 2013 and I've noticed I don't have the [Resource Departments] field in the MSP_EpmResource_UserView. The field and lookup table exist when I look at custom fields and tables in PWA, the lookup table is populated, and I can see resources with department values in both PWA and Project Pro, but I can't seem to query it. When I look at the view, it's not there.

    Any ideas?

    Tuesday, July 25, 2017 1:58 PM

All replies

  • Hi Kevin,

    I have something similar, and what I had to do, is to edit a user from Resource Center, after that, the view is regenerated and I could already make use of it, try this may can help you, the same happens with Project User View, you have to publish some Project to get this view available in db after upgrade PS 2013.

    Also you can add a new test value to department lookup table, maybe this can also help you to refresh the db.


    Ray Chapa


    Wednesday, July 26, 2017 9:23 PM
  • Ray,

    I sincerely appreciate the response.  You're correct, we had to open our project level custom fields, rename them, then put their names back, after upgrading to 2013.  However, I haven't had any luck with the [Resource Departments] field.  I'm able to use ALL other resource custom fields in my queries, including those that have lookup tables, but [Resource Departments] does not show up.  I've tried editing a user from the Resource Center, but it didn't change anything.  I've included a couple of screenshots.  You can see that the field is indeed in the "Edit Resource" view, I can see it and edit it, but if you'll notice the screenshot from the database, that field isn't included in the view.

    Kevin

    Thursday, July 27, 2017 1:39 PM
  • Hi Kevin,

    Try to recreate RDB, create an administrative backup then try to restore with this administrative backup, this takes a long time, take a look in queue server to see what happens, maybe this can restore everything well.

    Also you can take a look on this Brian Smith post 


    Ray Chapa

    Thursday, July 27, 2017 4:01 PM
  • I'll have our DBA take a look.  I've checked out the Brian Smith post.  Definitely works in 2016, but that command apparently isn't available in 2013.  We tried.

    Take a look at this though.  Are you familiar with this query?  I've used it in the past for task and project custom fields.

    SELECT CustomFieldName, ColumnPoolTableName, ColumnPoolColumnName
    FROM MFN_Epm_GetAllCustomFieldsInformation()
    WHERE EntityName = N'Resource'

    Check out the following screenshots.  Cleary I have the Resource Departments field defined and the Departments lookup table populated.  I mean, I'm actively using it!  But look what the above query returns.  How is this even possible?

    Thursday, July 27, 2017 4:22 PM