none
Sign UWP application ?

    Question

  • Hello,

    I ported a LOB WP 8.1 application to UWP, it will be distributed by Intune on W10m devices. For that in 8.1, we signed the application with a Symantec certificate. To sign the appxupload package, I used BuildMDILAPPX.ps1, which obviously does not work for the UWP packages... I tried SignTool.exe, it also does not work.

    Is anyone have a solution to sign the ARM appxbundle? (it does not work from the packaging of package.appxmanifest tab in Visual Studio too).

    Thanks in advance


    MATHIEU Alexis


    Tuesday, March 15, 2016 3:31 PM

All replies

  • Hi MATHIEU Alexis,

    I’m not sure that you how to use BuildMDILAPPX.ps1 to make app package. You could try my following steps:

    1) makeappx pack /v /d C:\XXXXXXXXX\bin\ARM\Debug /p C:\XXXXXX\\bin\ARM\Debugappx.appx /l

    2) open powershell

    3) optional
    powershell.exe Set-ExecutionPolicy Unrestricted

    4) powershell.exe -file "C:\Program Files (x86)\Microsoft SDKs\WindowsPhoneApp\v8.1\Tools\MDILXAPCompile\BuildMDILAPPX.ps1" -appxfilename C:\XXXXXXXXXX\bin\ARM\Debugappx.appx -pfxfilename C:\XXXXXXXXX\Certificates\XXXX.pfx -password XXXXX

    Best Regards,

    Xavier Eoro


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 16, 2016 8:09 AM
  • Hello,

    Thank you for your answer.

    1. It worked (from w10 machine)

    4. It failed (from w8.1, I didn't try from w10).
    In the console, the error is the same as if I try to use the original appxbundle file


    Here is the console output:
    C:\windows\system32>powershell.exe -ExecutionPolicy Unrestricted -File "c:\progr
    am files (x86)\Microsoft SDKs\WindowsPhoneApp\v8.1\Tools\MDILXAPCompile\BuildMDI
    LAPPX.ps1" -appxfilename "C:\Users\...\Debugappx
    .appx" -pfxfilename "C:\Users\...\xxxx.pfx" -password xxxx -inputFold
    er "C:\Users\...\input" -outputfolder "C:\Users\...\output"
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


    UnPack the Appx
    MakeAppx failed to extract C:\Users\...\Debugappx.appx to C:\Users\...\input\Debugappx with error:(1). See C:\Users\...\output\MakeAppxdlog.txt for de
    tails.
    breakt : Le terme «breakt» n'est pas reconnu comme nom d'applet de commande,
    fonction, fichier de script ou programme exécutable. Vérifiez l'orthographe du
    nom, ou si un chemin d'accès existe, vérifiez que le chemin d'accès est
    correct et réessayez.
    Au caractère C:\program files (x86)\Microsoft
    SDKs\WindowsPhoneApp\v8.1\Tools\MDILXAPCompile\BuildMDILAPPX.ps1:300 : 8
    +        breakt
    +        ~~~~~~
        + CategoryInfo          : ObjectNotFound: (breakt:String) [], CommandNotFo
       undException
        + FullyQualifiedErrorId : CommandNotFoundException

    (sorry Powershell error message is displayed in french)




    Thursday, March 17, 2016 12:30 PM