none
Failed to run face basics RRS feed

  • Question

  • Hello,

    I have this strange problem with one of my desktop PCs (core i7 with excellent usb3.0 performance) I am unable to run face basics on it however other pre-compiled samples(color, body, depth and ir) run fine. I tested my Kinectv2 on another machine where face basics it works fine and I am able to record facial animation parameters using my own code(which is the main goal). I previously thought that problem can be because of not copying the correct model and dll files(Kinect20.Face.dll) but this doesn't seem to be the case.

    What can be the cause? Any suggestions? I have already tried reinstalling the latest drivers and sdk. Please let know if further info is required.


    Monday, January 12, 2015 11:32 AM

All replies

  • This is what I see on the screen. Body is being detected in Kinect Studio, however the face basics doesn't register. https://www.dropbox.com/s/zoj3za4m9paczn8/Screenshot%202015-01-12%2015.25.16.png?dl=0
    Monday, January 12, 2015 1:30 PM
  • Did you install the latest NVidia drivers?

    Carmine Sirignano - MSFT

    Monday, January 12, 2015 8:32 PM
  • Your suggestion worked :). Now, can I recover face tracking from previous recordings ( These recording were done without realizing the driver issue, we recorded all the streams including color though)? Face basics runs fine with new recordings but not with previous ones. We did this recordings (of couple of hours but in 5 min segments) as part of research work. It will be painful if all goes to waste.

    Any suggestions/possibility of recovering this face animations parameters? Please let me know.

    Thanks for the help.

    Tuesday, January 13, 2015 10:03 AM
  • You can try running the KinectStudioUtility to try and repair them. In KStudio you can confirm if there is IR data in the recordings and if there isn't any, then there will not be anything that can be generated from that.

    Carmine Sirignano - MSFT

    Tuesday, January 13, 2015 6:30 PM
  • Thanks, we do have the IR data in the recordings. Please guide me how to repair the file using KinectStudioUtility. I checked out the options it can take as input however there is no 'repair' option. Is this the tool you mentioned: http://msdn.microsoft.com/en-us/library/dn785527.aspx.

    Tuesday, January 13, 2015 9:27 PM
  • What does the IR data look like? You also have color, depth and body data in the files as well?

    Carmine Sirignano - MSFT

    Wednesday, January 14, 2015 8:47 PM
  • KinectStudio does show that IR stream is recorded but I get black screen upon running IR basics during playback of the recorded file. Yes color, depth and body is also recorded.

    Wednesday, January 14, 2015 9:54 PM
  • You can try running the KinectStudioUtility to try and repair them. In KStudio you can confirm if there is IR data in the recordings and if there isn't any, then there will not be anything that can be generated from that.

    Carmine Sirignano - MSFT

    How can we repair using KinectStudioUtilty?

    Friday, January 16, 2015 8:47 PM
  • I was referring to the wrong tool, you will want to us ksconvert, but his will only work if you recorded raw(xrf) files.

    http://msdn.microsoft.com/en-us/library/dn785508.aspx

    If the format is xef than the recording is only going to work in non-connected playback mode only. So you should be able to use it in VGB, but for full face scenarios, it will not, since it is missing data required to generate the data required for connected playback.


    Carmine Sirignano - MSFT

    Monday, January 19, 2015 5:43 PM