none
Did Windows 8 Update Break Emulators?

    Question

  • The mobile emulators for Visual Studio 2015 have unexplainably stopped working for me. It's not just my PC, but all the developers in my department are reporting that their emulators stopped working within the last two weeks. I've done a lot of searching for solutions, but have come-up with none.

    The Problem:

    • In Visual Studio 2015 Update 1 on a Windows 8.1 PC, debug an application using any Windows 8.1 emulator.
    • The emulator opens and displays "Loading...", then "Starting Windows OS"...
    • After several minutes, the following message pops-up:


    • The emulator starts-up with the OS loaded, but not the application.
    • I tried opening an emulator in Visual Studio 2013 and get the same issue.

    Solutions That Didn't Work

    • Running a "Repair" on the Windows Phone Emulator SDK packages in Program Files
    • Removing all Windows Phone related virtual machines in the Hyper-V Manager
    • Removing all Windows Phone related virtual switches in the Hyper-V Virtual Switch Manager

    I can't seem to find any logs stating what exactly is going wrong other than the pop-up shown above.  I have noticed that there were considerable Windows updates to my PC over the past week or so, including at least one security update.

    Is anyone else experiencing this issue?  Have you resolved it?  Any tips for troubleshooting this?

    • Moved by IoTGirl Wednesday, March 23, 2016 7:34 PM Not Smart Device Development
    Wednesday, March 23, 2016 1:27 PM

Answers

  • I finally found a real solution to this problem.  A firewall rule appeared to be blocking access to the emulator.  To resolve it:

    1. Open the Windows Firewall with Advanced Security thingamabob, then click the Windows Firewall Properties link:



    2. Select the Public Profile
       tab and click the Customize... button for the Protected network connections setting:



    3. Uncheck the Network connection listed as vEthernet (Internal Ethernet Port Windows Phone Emulator Internal Switch):

    • Marked as answer by ImNoScrub Friday, April 29, 2016 3:12 PM
    Friday, April 29, 2016 3:12 PM

All replies

  • Hi ImNoScrub,

    Since your emulators working fine before and you mentioned that there were some Windows Updates installed during these time, I suggest you uninstall these updates one by one to check whether this issue caused by one of the updates.

    Then please try with following steps to check whether it can fix your problem or not.

    Open Hyper-V Manager -> Computer name -> Virtual machine -> Virtual Switch Manager -> Windows Phone Emulator Switch -> Private Network -> Apply, OK

    Then restart your emulator.

    If it still can't resolve the problem, please refer to the discussion in below thread, which is similar with yours. Hope that can help you.

    http://stackoverflow.com/questions/20718897/the-windows-phone-emulator-wasnt-able-to-connect-to-the-windows-phone-operating

    Best Regards,
    Weiwei

    Thursday, March 24, 2016 8:26 AM
    Moderator
  • Thank you for your response, Weiwei.  Unfortunately, I had already tried all the things you suggested, including those in the StackOverflow post.  I have no control over the anti-virus or firewall software on my PC, so I'm going to ask our desktop support team if they changed something.
    Thursday, March 24, 2016 12:33 PM
  • I had the anti-virus software on my PC disabled and that made no difference.

    I see that since March 9th, there have been 13 Windows security updates installed.  The next step is going to be building-up a PC without those updates and see if they caused the issue.

    Thursday, March 24, 2016 4:53 PM
  • Hi ImNoScrub,

    >>I tried opening an emulator in Visual Studio 2013 and get the same issue.

    So the emulator doesn't work on both VS2013 and VS2015, is it right? Please try uninstall and reinstall the Windows Phone Emulator to check whether it can fix this issue.

    >>The next step is going to be building-up a PC without those updates and see if they caused the issue

    I will wait for your response for this step. According to your description, I think the mostly problem is caused by one of the updates.

    Best Regards,
    Weiwei

    Friday, March 25, 2016 1:45 AM
    Moderator
  • I finally found a real solution to this problem.  A firewall rule appeared to be blocking access to the emulator.  To resolve it:

    1. Open the Windows Firewall with Advanced Security thingamabob, then click the Windows Firewall Properties link:



    2. Select the Public Profile
       tab and click the Customize... button for the Protected network connections setting:



    3. Uncheck the Network connection listed as vEthernet (Internal Ethernet Port Windows Phone Emulator Internal Switch):

    • Marked as answer by ImNoScrub Friday, April 29, 2016 3:12 PM
    Friday, April 29, 2016 3:12 PM