none
Event Hub and Consumer Groups

    Question

  • Hi folks,

    I'm attempting to deploy an Event Hub through the portal and am running into an issue whereby the Consumer Group for the hub is either removed or deleted when you navigate away from the Event Hub blade. I've tried clearing browser cookies and have tried this across Chrome, IE & Firefox and also from my mobile, but the behaviour persists.

    To reproduce the behaviour i've been taking the following steps:

    1. Search the Marketplace for "Event Hubs"
    2. Specify the name, 'Standard' pricing tier, new or existing resource group (Doesn't seem to matter) and select West Europe as the Location. Click Create.
    3. After the name space has been created, click into it to open the blade and add an Event Hub. Give it a name and leave the other settings as default.
    4. Click into the event hub to open the blade and you'll see a Consumer Group called "$Default" has been added.
    5. Navigate away from the blade (I usually click back to the "All Resources" blade)
    6. Once it loads, go back into the blade to view the Consumer Group that was created. The CG has been removed and I see a black bar with "Not found" across the blade.

    This is preventing me adding an endpoint or route to an IoT Hub, and also preventing me from creating a Function App.

    Is this expected behaviour? I've had a couple of people try this and they experience the same behaviour...

    Thanks, Scott


    Tuesday, February 21, 2017 4:15 PM

All replies

  • I have tried the steps which you have mentioned and created an Event Hub successfully without any issues. Even after refreshing the portal (clicking back to "All Resources" blade), I can see the CG which was created by name "$Default". I would suggest you try it again by deleting the namespace and creating through different browser on private mode or incognito window.

    Wednesday, February 22, 2017 1:59 PM
    Moderator
  • Have tried those steps. I even went as far as to dig out an old laptop I haven't used in 5 years and experienced the same issue.

    I've got five colleagues experiencing the same issue across a couple of subscriptions. Once the CG is 'dropped', i'm unable to recreate it - An error is thrown with no error code. I'm also unable to add any Shared Access policies to the hub. Same error thrown, without an error code.

    Wednesday, February 22, 2017 2:12 PM
  • We are working on the issue and we will roll out the portal fix as soon as possible. Stay tuned.

    In the meantime, you can create consumer groups through classic portal, our many api clients or through service bus Explorer tool.

    Thursday, February 23, 2017 6:31 AM
    Moderator