none
ReceivedTime (PR_MESSAGE_DELIVERY_TIME) always set to nearest minute; other props set correctly. RRS feed

  • Question

  • I am having a strange issue with PR_MESSAGE_DELIVERY_TIME - For ALL my outgoing mail items, it always rounds to the nearest minute, i.e. the seconds are always :00. I can understand if the OOM was doing this, but that's not the case.

    All the other MAPI Time properties (from using OutSpy): PR_CLIENT_SUBMIT_TIME, PR_CREATION_TIME, PR_LOCAL_COMMIT_TIME & PR_LAST_MODIFICATION_TIME
    are always set correctly. The properties are also correctly set on incoming mail.

    Any help/advice greatly appreciated.  

     (OL2007, Win7x64, Exch Srvr 2007) 
    Monday, March 12, 2012 9:19 PM

Answers

All replies

  • On further investigation, using a Virtual Machine with a Clean OL2003 installation, the same issue occurs....suggesting the problem is with Exchange 2007. 
    Monday, March 12, 2012 9:47 PM
  • Are the messages received from the Exchange server?

    Wha if you configure a POP3 accout and deliver a message to the Exchange mailbox?


    Dmitry Streblechenko (MVP)
    http://www.dimastr.com/redemption
    Redemption - what the Outlook
    Object Model should have been
    Version 5.2 is now available!

    Monday, March 12, 2012 10:43 PM
  • hi dmitry....even more strange...sending from a pop account at my server gives the same problem on PR_MESSAGE_DELIVERY_TIME; 

    the PR_MESSAGE_DELIVERY_TIME is correctly set when sending using OWA, after which I can see the sent email directly in the Admin "Sent Items" folder and check props through OutSpy;  my server has OL2003 on it and my LAN PC is OL2007 - both seem to display the problem; 

    I have tried an IMAP account too...same problem; 

    (Just FYI...On checking all my email accounts, it seems I have had the problem since Jun. 2009, when I think I had some major email problems)

    Monday, March 12, 2012 11:27 PM
  • further update....it seems the problem is only occurring on Mail Items; Post Items, Calendar, Contact, Task & Journal Items have PR_MESSSAGE_DELIVERY_TIME correctly set. 
    Tuesday, March 13, 2012 7:45 AM
  • Can you connect to the same mailbox from a different machine and try to send a mesage?


    Dmitry Streblechenko (MVP)
    http://www.dimastr.com/redemption
    Redemption - what the Outlook
    Object Model should have been
    Version 5.2 is now available!

    • Marked as answer by JimDenmark Wednesday, March 14, 2012 10:08 AM
    Wednesday, March 14, 2012 6:59 AM
  • from another machine.... PR_MESSAGE_DELIVERY_TIME set correctly ! Then I go back to my main PC and try again, and bizarrely it is now setting the times correctly....wierd. Thanks for taking the time to consider. 
    Wednesday, March 14, 2012 10:08 AM