locked
Library list - item level edit permissions RRS feed

  • Question

  • I recently setup an employee directory and I've been trying to configure it so that every member has edit permissions to only their list item.  Since every item in the list was created by an admin, the 'advanced settings->Edit Access->Only their own' doesn't work.  What is the easiest way to get this to work?  I've tried going into an individual item and granting edit permission on that item to the respective, user which didn't work. 

    Thank you,

    Josh

     


    There is no signature
    Tuesday, January 27, 2009 3:30 PM

Answers

  • Hello Josh,

     

    Thanks for your feedback.

     

    Could you let me know the details about the following description:

     

    > We configured the list so it's read-only by everyone and then went into each item and enabled each item to only be editable to the person who should be able to edit it.  This did not work.

     

    Based on my experience and test, this assignment of permissions should work without problem.

     

    There is possibility that if you test multiple users in only one Windows login session, the credential may be kept even though you have login as another user in SharePoint Website. In such a case, please log on Windows as the user you want to test, then try to edit the document again.

     

    Thanks for your cooperation.  

     

    Best Regards,

    Lionel

    • Marked as answer by IMAtMyWitsEnd Thursday, February 5, 2009 9:20 PM
    Friday, January 30, 2009 5:56 AM

All replies

  • The simplest option is to deal with sharepoint views. Create a view to the list using [ME] filter, so that the view renders only the items created by the user. Make the view default to sharepoint list. So that the user can't see the items created by other users. This would restrict the users not to update the items created by others 
    Sundar Narasiman
    Tuesday, January 27, 2009 4:26 PM
  • 1) An admin creates the items.

    2) The list is an employee directory, the purpose of which is for everyone to be able to see the items (other employees) on the list.

     


    There is no signature
    Tuesday, January 27, 2009 5:13 PM
  • Hello Josh,

     

    I think the only way is to give item-level permission to the curtain user.

     

    Since WSS 3.0 and MOSS 2007 have security trimming feature, the items that the user doesn’t have read permission will not show. Please note to not give other user any permission to the item which he shouldn’t see.

     

    Thanks.

     

    Best Regards,

    Lionel

    Thursday, January 29, 2009 12:30 PM
  • Lionel,

    Thank you for your suggestion, but I cannot stress enough, one of the requirements is that any user SHOULD see all items in the list, but only edit an item assigned to them. 

    We configured the list so it's read-only by everyone and then went into each item and enabled each item to only be editable to the person who should be able to edit it.  This did not work.  Did I make an assumption that security trimming would be complex enough to allow read-only and read-edit simultaneously to different people. 

    -Josh


    There is no signature
    Thursday, January 29, 2009 3:03 PM
  • Hello Josh,

     

    Thanks for your feedback.

     

    Could you let me know the details about the following description:

     

    > We configured the list so it's read-only by everyone and then went into each item and enabled each item to only be editable to the person who should be able to edit it.  This did not work.

     

    Based on my experience and test, this assignment of permissions should work without problem.

     

    There is possibility that if you test multiple users in only one Windows login session, the credential may be kept even though you have login as another user in SharePoint Website. In such a case, please log on Windows as the user you want to test, then try to edit the document again.

     

    Thanks for your cooperation.  

     

    Best Regards,

    Lionel

    • Marked as answer by IMAtMyWitsEnd Thursday, February 5, 2009 9:20 PM
    Friday, January 30, 2009 5:56 AM
  • Lionel,

    Thank you for confirming the security trimming should perform in that manner.  I had tested with multiple sessions as well as with multiple users to make sure there was no security caching interfering and the results were the same, privileges were inconsistent.  I guess the only conclusion I can come to is that we're dealing with a bad installation. 

    I was able to workaround the issue by allowing edit to all and then creating a custom list editor page in SharePoint Designer and then adding an xslt test to verify privileges to it.

    Regards,
    Josh

    There is no signature
    Thursday, February 5, 2009 2:02 PM
  • HI Josh,

    Thats cool... Actually in your previous post you had written that the Configuration did'nt work. but you didnot actually specify now what the users those were added with read and rights permission can do with the list items.


    Khanna
    Thursday, February 5, 2009 2:45 PM
  • User TEST has edit-none access to the list and contribute priv to their respective items.
    User TEST can view all items in the list, but can only see the 'Edit' button on his item he has 'Contribute' access to.
    User TEST can go to the edit page, make modifications.
    When 'OK' button is clicked the Access Denied Page is reached.

    As I was writing this I just got it.  I had to change the List Settings->Item Edit Access to 'All Items'.  I was under the impression that the item-level edit access would override the list setting.  It appears to do this for the opposite; List - Edit All Items; w/ an item-level read-only prevents users from editing. 

    It appears to be working correctly now.  Too bad it took so much guessing. 

    Thank you for your help.

    Regards,
    Josh


    There is no signature
    Thursday, February 5, 2009 5:25 PM