locked
Unable to debug "Script" (classic asp): "the correct version of pdm.dll is not registered" RRS feed

  • Question

  • I have started getting an issue when trying to Attach to IIS and debug Classic ASP (not ASP.Net WebForms, but Classic ASP).

    When visual studio tried to load the source code for break point it hits, I get an error that says:

    "Unable to open script document. The correct version of pdm.dll is not registered. Repair your Visual Studio installation, or run 'regsvr32.exe "%commonprogramfiles%\Microsoft Shared\VS7Debug\pdm.dll"'.

    I have tried both suggestions in the error message and neither work.

    Any suggestions?

    Sunday, July 13, 2014 11:49 PM

Answers

All replies

  • I have also tried uninstalling VS and re-installing.  Same issue.
    Monday, July 14, 2014 12:53 AM
  • Hi gregpakes,

    >>"Unable to open script document. The correct version of pdm.dll is not registered. Repair your Visual Studio installation, or run 'regsvr32.exe "%commonprogramfiles%\Microsoft Shared\VS7Debug\pdm.dll"'.

    Maybe you need to register it.

    http://stackoverflow.com/questions/12302663/visual-studio-script-debugging-invalid-process-type-for-inetinfo-exe

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, July 15, 2014 7:35 AM
  • As per my original post, I have already tried that. It didn't work.
    Wednesday, July 16, 2014 1:54 PM
  • Hi gregpakes,

    If possible, please restart your IIS, test it again.

    If you create a new site, what about the result?

    In addition, what is your real Environment like the IIS/VS/IE version?

    http://stackoverflow.com/questions/1138175/how-do-you-debug-classic-asp

    http://stackoverflow.com/questions/14343268/visual-studio-fails-debugging-javascript-in-ie9-says-the-correct-version-of-p

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, July 17, 2014 9:03 AM
  • Hi,

    I have restarted IIS and rebooted the machine.  It didn't help.  I will see if creating a new site helps.

    The environment is: Windows 8.1, IIS 8.5, VS 2013 Update 2, IE 11.0.9600.17207.

    thanks,

    Greg

    Thursday, July 17, 2014 10:55 AM
  • Hi Greg,

    Does it work well if you create a new site?

    When you open the Attach Process windows, do you select "Show processes from all users"? Please also select the correct "Attach to:" type.

    But if a simple site works well, I doubt that it is not the VS Debugger tool issue.

    To really repro this issue, Maybe the IIS forum would better for this issue like this thread:

    http://forums.iis.net/1044.aspx

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, July 18, 2014 7:32 AM
  • "When you open the Attach Process windows, do you select "Show processes from all users"?"

    I'm confused? How is this relevant? That simply filters the list of processes.  I am connecting to the correct w3wp.exe, so i'm not sure how the pre-filtering is relevant.

    "Please also select the correct "Attach to:" type."

    Yes - I am selecting "Script", which is how to debug Classic Asp.  I have been using this method to debug Classic Asp for years.

    I will test on a simple site.

    thanks,

    Greg

    Monday, July 21, 2014 7:33 AM
  • I have managed to get this working by disabling client side debugging in IIS.

    It's not solved the issue, but at least I can debug the code now.

    thanks,

    Greg

    Monday, July 21, 2014 11:25 AM
  • Hi Greg,

    >>I have managed to get this working by disabling client side debugging in IIS.

    It's not solved the issue, but at least I can debug the code now.

    Thank you for sharing your workaround here. If it works well after you disable the settings in IIS, I still doubt that it is not the VS issue, maybe it would be related to the IIS or others, does it work well if you create a simple site now? Would you mind posting a new case in the IIS forum?

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, July 22, 2014 3:20 AM
  • Hi Greg,

    Did you uninstall IE or VS on this system. If so, can you please take a look at: http://stackoverflow.com/questions/14343268/visual-studio-fails-debugging-javascript-in-ie9-says-the-correct-version-of-p

    This doesn't look at all like a debugger issue, so you might get better answers in the IIS forum

    Thanks,

    Maria

    Wednesday, July 23, 2014 6:00 PM