locked
installation needed on 64 bit server for crystal report RRS feed

  • Question

  • User-29606770 posted

    website in asp.net 2010 with crystal report works fine on local bt not on server.It showes error:

    An error has occurred while attempting to load the Crystal Reports
    runtime. Either the Crystal Reports registry key permissions are insufficient,
    or the Crystal Reports runtime is not installed correctly. Please install the
    appropriate Crystal Reports redistributable (CRRedist*.msi) containing the
    correct version of the Crystal Reports runtime (x86, x64, or Itanium) required.
    Please go to http://www.businessobjects.com/support for more information.

     want proper solution

    Tuesday, October 11, 2011 9:09 AM

Answers

  • User1918766559 posted

    Crystal Reports does not initialize with x64 configuration. Please change the configuration to x86 and it now initializes. 

    Steps: 

    Go to your application project, right click, and select "Properties"

    On the Build tab, find the Platform Target combo box. It probably says, "Any CPU". Change this to x86 and your project will compile for 32 bit only, thus eliminating the issue.

    Thanks,

    Anindita

    http://anindita9.wordpress.com

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, October 11, 2011 9:16 AM

All replies

  • User1918766559 posted

    Crystal Reports does not initialize with x64 configuration. Please change the configuration to x86 and it now initializes. 

    Steps: 

    Go to your application project, right click, and select "Properties"

    On the Build tab, find the Platform Target combo box. It probably says, "Any CPU". Change this to x86 and your project will compile for 32 bit only, thus eliminating the issue.

    Thanks,

    Anindita

    http://anindita9.wordpress.com

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, October 11, 2011 9:16 AM
  • User1196771204 posted

    Hi amrutagore,

    Please kindly check all the steps below in order to run your Crystal Report properly:

    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it with asphostcentral.com

    Please mark this response as an "answer" if it helps you. Thanks heaps

    Tuesday, October 11, 2011 11:58 PM