none
SDIDE++ RRS feed

  • Question

  • The SBIDE is instaled th the prorams(x86 folder ->Microsoft->SmallBassic. All os the files that needed to be there are there.Still clikcing on SBIDE.exe produces nothing.
    Friday, October 18, 2013 9:51 AM

Answers

All replies

  • Is this Gungan's IDE?

    Thanks!


    Ed Price, SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Friday, October 18, 2013 9:36 PM
    Owner
  • Ed: Yes, that is my IDE. You can check it out here: http://social.msdn.microsoft.com/Forums/en-US/e94dc8ae-bb16-4e29-8862-4e953f7e007c/sb-ide-its-here?forum=smallbasic

    Sorry you are still having troubles, avdiel. Did you try my suggestion over on the other thread? I suggested manually copying the following files into the SB IDE++ folder:

    ComponentModel.dll, LanguageService.dll, SB.exe, SmallBasicCompiler.exe, StringResources.dll and ToolFramework.dll

    Above is a screenshot of all the folders/files you should have in your SB IDE++ folder.


    Please mark any answers and "vote as helpful" any posts that help you!


    Friday, October 18, 2013 10:09 PM
    Answerer
  • Hello gungan37,

    the same prob for me too. Each time i try it from original state, the mentioned 6 files are copied to SBIDE++ main folder as well as scilexer.dll, scilexer64.dll and scintilla.dll are copied to system32. I'm already trying it since 2 days to make it start. Maybe made a mistake before the first start at all. Because i'm on a 32bit machine, i deleted all three *64*.dll files. Then on first run ("SB IDE++ Loader.exe"), a black glass console poped up with error message (SciLexer64.dll not found), but i clicked on "Continue" and that was it. Black Glass window showed some infos (... found etc.), then closed this console window, placed the three *64* files to main folder again and tried a second 'first' start, but nothing more happened. "SB IDE++ Loader.exe" and "SB IDE++.exe" shows no reaction, but "SB IDE++ Reflector.exe" Gui starts. Thats all!

    Microsoft Windows [Version 6.1.7601],  Home Premium, 32 bit, german, Frameworks v1.0.3705, v1.1.4322, v2.0.50727, v3.0, v3.5, v4.0.30319 installed and latest MS patches uptodate.

    Maybe relevant: HKCR\.sb

    HKCR\.sb\ShellNew: FileName    REG_SZ    Template.sb

    associated to HKCR\SmallBasicScript, and there

    HKCR\SmallBasicScript\shell\Compile\command: "C:\Program Files\Microsoft\Small Basic\SmallBasicCompiler.exe" "%1"

    HKCR\SmallBasicScript\shell\Open\command: "C:\Program Files\Microsoft\Small Basic\SB.exe" "%1"

    HKCR\SmallBasicScript\shellex\\{8895b1c6-b41f-4c1c-a562-0d564250836f}: default  REG_SZ  {1531d583-8375-4d3f-b5fb-d23bbd169f22}  ; QuickView

    Any suggestion ??

    Btw, here ist fully translated IO Extension.De.xml.

    PS: What i forgot to mention: Obviously every trial start an empty file %TEMP%\xxxxxxx.tmp (eg. pxv8113.tmp) is created. If that helps in any way.

    Saturday, October 19, 2013 12:11 AM
    Answerer
  • Thanks so much for the translation!

    BTW I am setting up a Windows 7 32 bit virtual machine to test the IDE in a clean 32 bit environment. I hate to say it but I forgot about 32-bit and only tested on W7 and W8 64 bit versions.


    Please mark any answers and "vote as helpful" any posts that help you!

    Saturday, October 19, 2013 12:26 AM
    Answerer
  • The 32-bit issues now appear to be fixed (special thanks to beta tester Jibba Jabba!) You can get the 32 bit version here: http://social.msdn.microsoft.com/Forums/en-US/e94dc8ae-bb16-4e29-8862-4e953f7e007c/sb-ide-its-here-update-32-bit-issues-fixed?forum=smallbasic

    Please mark any answers and "vote as helpful" any posts that help you!

    Saturday, October 19, 2013 5:45 PM
    Answerer