none
LitDev LDDataBase ListView Field Labels RRS feed

  • Question

  • When the Listview is displayed LDDatabase.Query the fields are shown across the top of the listview. I've set the first field as ID. When the field values are displayed if they are larger than 1 character they are clipped in this field.  I know I can goto the fields at the top and widen that field by by moving the vertical bar in the field name row. I was wondering if there is a way that this would not happen. Be nice if the field width adjusted to the size of the text in the field.

    Thanks,


    JR

    Friday, July 4, 2014 8:41 PM
    Answerer

Answers

  • LitDev,

    I tried setting this up in a small program, but couldn't get it to fail. I even set the index at 3 digits and it worked like it should. So, I went back to the failing program. In the program I had previously created the listview and had it hidden. Later in the program I did the query and then showed the listview by  using Controls.ShowControl. Doing it this way caused the ID field text to be clipped. So, I changed the program to show the Listview right before I did the query and it worked like it should.

    Thanks,


    JR

    Saturday, July 5, 2014 4:41 AM
    Answerer

All replies

  • Can you post a simple sample code - for me the listview seems to resize to fit 2 character IDs, for example my sample included with download if I add some extra table rows > 10.

    Friday, July 4, 2014 9:59 PM
    Moderator
  • LitDev,

    I tried setting this up in a small program, but couldn't get it to fail. I even set the index at 3 digits and it worked like it should. So, I went back to the failing program. In the program I had previously created the listview and had it hidden. Later in the program I did the query and then showed the listview by  using Controls.ShowControl. Doing it this way caused the ID field text to be clipped. So, I changed the program to show the Listview right before I did the query and it worked like it should.

    Thanks,


    JR

    Saturday, July 5, 2014 4:41 AM
    Answerer