none
Problem enabling .Net Framework 3.5 on Windows 10 RRS feed

  • Question

  • Hi, I am having trouble enabling .Net Framework 3.5 on my Windows 10 PC. While I was installing SQL on my PC, the installer suggested to install .Net Framework 3.5. Since then I have tried multiple options to install .Net Framework 3.5. I tried enabling from "Turn Windows Feature on or off" when it didn't work, I also downloaded offline as well as online installer and tried that too. But all these option lead to one error. 

    Error code: 0x800F081F (See image reference)

    As it says to make sure you're connected to internet. It doesn't even work when I am connected to internet too.

    Can anyone please instruct me here?

    Thanks

    Problem enabling .Net Framework 3.5 on Windows 10

    Friday, October 9, 2015 12:05 PM

Answers

All replies

  • Hi Luzan,

    Error code 0x800F081F means that we can’t find a source for the files we need to install the feature you’re requesting. (Your refereed image already mentioned this information)

    I would suggest please have a look into below related thread for help,

    Installing Framework 3.5 fails with error code 0x800F081F - default solutions don't work


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Marked as answer by Luzan Sunday, October 11, 2015 3:04 AM
    Friday, October 9, 2015 12:10 PM
  • "I tried enabling from "Turn Windows Feature on or off" when it didn't work, I also downloaded offline as well as online installer and tried that too. But all these option lead to one error. "

    You cannot use the standard .NET 3.5 web or offline installers to install .NET 3.5 on Windows 10.

    As turning Windows features on did not work for you, please try the following:

    https://support.microsoft.com/en-us/kb/2734782

    (applies to Win 10 as well)

    Friday, October 9, 2015 2:29 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  You may need to restart afterwards.

    If this works for you please mark as answer.


    • Edited by Paul Bill Wednesday, January 4, 2017 3:58 PM
    • Proposed as answer by JoseMR Monday, March 20, 2017 1:42 PM
    Wednesday, January 4, 2017 3:57 PM
  • Yes thank you , worked as expected.


    JM

    Sunday, March 19, 2017 3:35 AM
  • Resolved my problem God bless you !

    Monday, March 20, 2017 6:25 PM