none
Installation Did Not Succeed! 4.0! RRS feed

  • Question

  • I'm not sure what the problem is, but this is the log file:

     

    OS Version = 6.0.6001, Platform 2, Service Pack 1
    OS Description = Vista - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\4763ec8c042a799d6a8dd5c9f616f556\\Setup.exe /x86 /x64
    TimeZone = Pacific Daylight Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
     
     
     
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
       
    Number of applicable items: 12
    Exe (C:\4763ec8c042a799d6a8dd5c9f616f556\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\4763ec8c042a799d6a8dd5c9f616f556\Windows6.0-KB956250-v6001-x64.msu) failed with 0x371b - One or more required members of the transaction are not present. .
     
    Final Result: Installation failed with error code: (0x0000371B), "One or more required members of the transaction are not present. " (Elapsed time: 0 00:00:24).

     

    I'm using Vista 64-bit.

    Please help!


    Tuesday, May 10, 2011 10:39 PM

Answers

All replies

  • Use Aaron Stebner's cleanup tool to get rid of any leftovers from the failed install. The tool has been updated to deal with all frameworks currently available, including 4.0:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Then, try the 4.0 standalone installer after disabling your AV and anti-malware programs.

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=en

    I also would install SP2 for Vista before trying .NET Framework 4.0 again, if I were you.

    Tuesday, May 10, 2011 11:13 PM
  • Hi Skatetheday,

    Thanks for your post.

    According to the eroor code(0x0000371B) and error message(One or more required members of the transaction are not present), I would suggest you run the System Update Readiness Tool to repair system files.
    System Update Readiness Tool: http://support.microsoft.com/kb/947821

    Then, please download the standalone installer to install .NET Framework again.

    Before install .NET Framework , please turn off your anti-virus/antispyware software; clean your %temp% folder (Start Menu >> Run >> Type "%temp%). Then run the setup with Administrator privilege.

    If you have any concerns, please feel free to let me know.

    Best Regards, 


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Thursday, May 12, 2011 6:37 AM
    Moderator
  • Thanks for all the help, but none of this worked, I tried everything and I still get the same "Did not succeed" error.

    This is my log file , if it matters. I think it's the same thing, but i'm not sure.

     

    OS Version = 6.0.6001, Platform 2, Service Pack 1
    OS Description = Vista - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\4852dffcb8f63b35aa\\Setup.exe /x86 /x64
    TimeZone = Pacific Daylight Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
     
     
     
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
     
    Number of applicable items: 12
    Exe (C:\4852dffcb8f63b35aa\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\4852dffcb8f63b35aa\Windows6.0-KB956250-v6001-x64.msu) failed with 0x371b - One or more required members of the transaction are not present. .
    Exe Log File: CBS.log
     
    Final Result: Installation failed with error code: (0x0000371B), "One or more required members of the transaction are not present. " (Elapsed time: 0 00:00:49).

     


    Thursday, May 12, 2011 7:47 PM
  • Hi Skatetheday,

    I apologize for the late response.

    I've checked and found that the Windows6.0-KB956250-v6001-x64.msu is an update rollup for the .NET Framework 3.5 SP1 in Windows Vista SP2 and in Windows Server 2008 SP2. Please see: http://support.microsoft.com/?kbid=982525.

    So I would suggest you firstly update your Windows Vista with the latest Service Pack 2, and install .NET Framework again. You can refer to this article for how to install install Windows Vista Service Pack 2: http://windows.microsoft.com/en-US/windows-vista/Learn-how-to-install-Windows-Vista-Service-Pack-2-SP2

    If the installation still failed, please collect the installation log files from "%temp%" folder with the Log Collection Tool: http://blogs.msdn.com/b/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Then send the vslogs.cab file in the %temp% folder to me (E-mail: v-anwu_at_microsoft_dot_com) for further diagnose.
    Note: Please attach the link of this post in the mail.

    Waiting to hear from you.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, May 19, 2011 11:25 AM
    Moderator
  • I had the same problem and this fixed it: 


    start > Run > regsvr32 wuaueng.dll

    Then Restart and try again

    Friday, April 27, 2012 3:53 PM