none
AppxManifest dependency on .Net Native Framework Package.

    Question

  • I got the following certification error when submitting to the app store.  I'm using Sqlite.Net-PCL from nuget which is what has forced me to use the Native Runtime, otherwise I get other certification errors.

    [My App Name] takes a dependency on Microsoft .Net Native Runtime Package 1.x framework but is missing the framework dependency declaration in the manifest.
    [My App Name] takes a dependency on Microsoft .Net Native Framework Package 1.x framework but is missing the framework dependency declaration in the manifest.

    How does one provide this dependency in the appxmanifest?  What's the syntax?

    I have this currently:

    <Dependencies>
    <TargetDeviceFamily Name="Windows.Universal" MinVersion="10.0.0.0" MaxVersionTested="10.0.0.0" />
    </Dependencies>
    Thursday, March 3, 2016 8:43 PM

All replies

  • Got the same error though I'm not using sqlite. Do you have older DLLs compiled from Windows 8.x?
    Saturday, March 12, 2016 1:55 PM