none
Issue with UART Bluetooth and EC7 RRS feed

  • Question

  • Hi All,

    I am working with AM35xx TI processor ported WEC7.

    I am using Atheros AR3k BT module connected to UART port 3 in my case.

    I enabled the universal loadable driver (SYSGEN_BTH) in the catalog file.

    Following are the reg settings what i did in the platform.reg file:

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\Transports\BuiltIn\1]
        "driver"="bthuart.dll"
        "flags"=dword:1
        "name"="COM3:"
        "baud"=dword:1c200
        "resetdelay"=dword:300
        
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\HCI]
        "driver"="bthuart.dll"
        "flags"=dword:1
        "name"="COM3:"
        "baud"=dword:1c200

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\sys]
       "Power"=dword:1                  ; Radio on by default
       "ScanMode"=dword:3               ; Radio is discoverable
       "DisableAutoSuspend"=dword:1     ; Allow suspend when connected

    When i try to use Bluetooth Manager application to scan the device i get the error as "Bluetooth hardware error 10050 (controller not present)

    Has any of you encountered the same error with WEC7 and resolved it.

    Any suggestions is greatly welcomed.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Monday, November 12, 2012 12:16 PM

All replies

  • Are you sure that the bthuart.dll transport is appropriate for your device? Couldn't be bthcsr.dll?

    Luca Calligaris lucaDOTcalligarisATeurotechDOTcom www.eurotech.com Check my blog: http://lcalligaris.wordpress.com

    Tuesday, November 13, 2012 9:24 AM
  • Thanks Luca,

    I tried with bthcsr.dll also but it didnt worked for me.

    Can you help me to know the difference between bthcsr and bthuart in the context of HCI?

    Is there any other catlog item to be included ?

    What are the probable cause of this error :

    Bluetooth hardware error 10050 (controller not present)

    I can understand from the error that H/W is not working , but why ?

    Electrically things are OK. In the scope i could see that the application sending 4 bytes of data, the value of the data is '*' '*' '*' '*' (four times star), the controller after sometimes returns the same value to the processor ie . four bytes of same data as four stars. This test i performed with bthsettings.exe.

    --- Misbah

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Tuesday, November 13, 2012 7:20 PM