How to make OS see a .vhd as removable. So that I can then select the ReadyBoost tab under properties? RRS feed

  • Question

  • From 1 DIYer to another, as ignorant as my questions may be.            
    <<<<  hoping for a tech-er with insight.>>>>

    I really just need to know how to make my OS see the .vhd I created (and am using without this issue for such, while booted into win7) as removable. So that I can then select the ReadyBoost tab under properties!
    If there is a policy I can make amendment to, or if there is a registry key modification you know of that can help me to accomplish this please reference such things in reply.
    Thank you for your time.

    What if anything I might be doing wrong when it comes to getting ReadyBoost to work on a .vhd that I have in windows server 2008 r2 sp1. I was able to set this .vhd up to auto mount and host ReadyBoost in my win7(x86) (preexisting)installation(prior to dual Boot to win2k8r2sp1), but I'm having issues accomplishing this in Win2k8r2sp1. <PS it still works and auto mounts on win7 side of things.>

    I am using the "update-able" R2 Workstation Converter v3. application. <(Found> I first used it to setup super-fetch and then I imported the boot-optimization.reg that I downloaded from the forum, and I am now seeing significant gains in terms of my boot-time.

    My physical memory is low (2Gb) and I was hoping to see more gains using a .vhd file that can be set to auto mount and work as ReadyBoost host. <(It dose auto mount just fine, but cant get the ready boot option)>

    I have good USB sticks but ports are a commodity, & well; I was just hoping to overcome this challenge the way I do most others,"Head On"!

    A quick minute of your time would be most appreciated!

    Thank you in advance for all your time.


    Thursday, March 15, 2012 1:49 AM

All replies

  • Hi,

    I assume within your hardware configuration that your system would have a lot of paging (pagefile.sys) operation.
    Because of low memory for the host and vhd os. My personla opinion is to use a win2k8r2 never below 4GB RAM.
    So fare I know the 2008 server does not support the readyboost function. This is for client os only.

    Best regards


    Thursday, March 29, 2012 4:43 PM
  • Thank you for replying,

    I was able to get Win2k8r2sp1 to support readyboost by importing the appropriate registry key and making a few miner modifications. For details see this link (ReadyBoost Instructions and Forum Discussions) or cut and paste "" without the "".

    Therefore my question above is with regards to a client OS. "In any OS how would one go about getting a .vhd to be seen a removable?" I'm certain that the only thing required to accomplish this is a small modification to one of the values in the registry under the .vhd's controller policy. But the question of which value needs modification and what that new value needs to be, is one that eludes me so far. (:> Its Above My Pay Grade)

    I am however, happy to report that I have bought a new System that supports VT and hyper-threading, as well as turbo boost, and has 8Gb of DDR3. So my previous desperation for a method to utilize readyboost within win2k8r2sp1 is far lessened. Pending the completion my endeavors with sysprep-ing my win2k8r2sp1 OS hard-disks, my transition to a platform that is Hyper-V capable will be complete. (For information on How to move your OS HDD's to a New Hardware setup see this link)  SysPre Methods, and Turorials. for Win7 OS or cut and paste "" without the "".

    That being said, I am still interested in finding a method to accomplish this goal. Its quite likely that others out there can benefit from the tactics we design, deploy, and test here.

    "For a detailed description of the method I used to make win2k8r2sp1 support readyboost please reply with inquires below. "


    Friday, March 30, 2012 3:50 PM
  • i think you should watch this . . .

    How to use virtual hard disk for Ready Boost (ram)

    • Proposed as answer by RPA601SG Thursday, May 17, 2012 12:07 PM
    Thursday, May 17, 2012 1:20 AM