locked
Asp.net classic application pool mode getting slow in Windows 2016 server RRS feed

  • Question

  • User-1627675772 posted

    Hi,

    can you please help to diagnosis the problem in ASP.Net classic mode application pool getting slow in IIS 10, it is not happening every day. sometime it is working getting for 2 to 3 days, then suddenly it is getting slow.

    Same application is hosted on other server and also hosted at cloud, but only one site having this issue.

    Requesting you, kindly help to identify the problem.

    Regards,

    Saroj

    Friday, September 27, 2019 8:09 AM

All replies

  • User61956409 posted

    Hi Saroj,

    Welcome to ASP.NET forums.

    sometime it is working getting for 2 to 3 days, then suddenly it is getting slow.

    In browser f12 developer tool network, you can try to capture request and check timeline for the network events of the request (such as Connecting, Sending, Waiting(TTFB), Downloading etc), then you can share the detailed information or screenshot so that we can troubleshoot the issue based on it.

    With Regards,

    Fei Han

    Monday, September 30, 2019 2:03 AM
  • User-1780421697 posted

    You need to capture the performance counter parameters of server to exactly get idea what is slowing down your system and its not really easy, some times we need to capture the snapshot of memory and analyze them later for analysis as well. Actually it has several factors may be you allocate the limited resources to your  application pool and that may slow down your server, may be there is memory leakage or may be you block threads when doing some long running operation so it depends what is slowing down your system and it only give you information when you capture performance counters.

    Another option is using Azure Application Insight , integrate it in your application and it will give you detail information of Server and Client parameters.  

    Monday, November 4, 2019 2:50 AM