locked
Black screen of death RRS feed

  • Question

  • User9148 posted

    Hi,

    I'm trying to build and debug an iOS app from Visual Studio. I have the latest Xamarin stable version installed and can run the test apps from Visual Studio or Xamarin. However when I run my own app (mvvmcross based) it only displays a black screen on the simulator.

    This code has been in development for 3 months and was working until very recently. The code will deploy if built using Xamarin Studio on the Mac.

    I've tried the following:

    1) Rolling back my code to a version over 1 month ago (that was definitely working). No luck. 2) Checking and changing the application settings for Application Name, version and identifer. No luck 3) Deleting the iPhone Simulator folder on the mac. No luck 4) Moving both PC and Mac to the Alpha Channel. No luck. 5) Multiple restarts of both machines. No Luck 6) Changed all my PCL projects to iOS library projects. No luck. 7) Targeting the 6.0 SDK rather than 6.1 SDK. No luck 8) Removing all code from my AppDelegate apart from an empty FinishedLaunching method. No luck

    I'm at a complete loss and would appreciate any help.

    Thanks

    Chris

    Friday, September 6, 2013 11:14 AM

All replies

  • User1430 posted

    Hi Chris,

    I'm sorry to hear you're having issues debugging your iOS app. Can I ask you to send over a copy of the logs from the simulator to our support team?

    You can get the logs from here: ~/Library/Application Support/iPhone Simulator/X.Y/Library/Logs

    X.Y is the version of iOS so you probably want to just paste this into finder:

    ~/Library/Application Support/iPhone Simulator/

    If you could zip up the contents and send it over to support@xamarin.com, we can get started on investigating whats going wrong for you.

    Cheers,

    Mike

    Friday, September 6, 2013 12:23 PM
  • User9148 posted

    Hi Mike,

    Thanks for the response. This is now an official bug at https://bugzilla.xamarin.com/show_bug.cgi?id=14566

    The only sub folder that appears in that folder is com.apple.itunesstored and it hs an empty itunesstored.log files. I deleted all the logs prior to a test run to make sure they were relevant.

    On a side note, I'm not getting any notifications from this forum. I think my preferences are set correctly.

    Cheers,

    Chris

    Monday, September 9, 2013 8:42 PM
  • User61584 posted

    Hi, is there any update to this topic? I've got the same problem, the iOS Simulator is getting black when i try to start debugging from Visual Studio 2013. Generally i have updated the latest version anywhere.

    It is noticeable that when i stop debugging from Visual Studio, the Simulator goes back to the iphone Home Screen. When i click on the (new) Application Button i wanted to debug before, the screen leaves black again.

    What can i do to debug this application correctly?

    In the log files you can't see anything, no errors are listed in the mtbserver.log.

    Visual Studio 2013 Update 4 Xamarin for VS 2013 v.3.11.590 Xcode v.6.1.1 Xamarin iOS Build Host v. 3.11.0.582 Xamarin iOS v. 8.10.1.64

    Regards S.N.

    Friday, June 5, 2015 12:50 PM