locked
Can adding an existing item (XaML) damage a Blend 2 project? RRS feed

  • Question

  • Hi,

    Spent a frustrating day looking for the cause of a problem with Blend 2 project. 

    Symptom: adding an existing item (XaML file exported from Design 2), caused loss of page.xaml, and other items from the calling Blend 2 Ag application project tab, reopening that project shows only .cs files, can't save project (points to non-existent path).

    Tried many options, including uninstalling and reinstalling Blend 2, Creating new Ag App projects to try adding that XaML file - problem persisted.

    Tried Adding different Design 2 XaML export to a new Ag App project, and problem NOT evident - seems the problem is caused by that one .xaml file.

    Besides the obvious (not using that .xaml file), where can I report this issue?  How should I pass along the .xaml that causes the problem, to proper support? Any others have this isse with adding XaML to a project?

    Thanks,

    BRN Conceptual Vistas, LLC
    • Edited by Brian27 Thursday, September 24, 2009 10:19 PM correction
    Thursday, September 24, 2009 10:18 PM

Answers

  • Hi Brian,
                   The XAML file might not be enough, is it possible for you to share a repro project with us? If so please send the project directly to me at navits@microsoft.com also did you give a try opening the solution in Blend 3?

    Thanks,
    Navit Saxena
    • Marked as answer by Brian27 Monday, September 28, 2009 6:36 PM
    Thursday, September 24, 2009 10:53 PM

All replies

  • Hi Brian,
                   The XAML file might not be enough, is it possible for you to share a repro project with us? If so please send the project directly to me at navits@microsoft.com also did you give a try opening the solution in Blend 3?

    Thanks,
    Navit Saxena
    • Marked as answer by Brian27 Monday, September 28, 2009 6:36 PM
    Thursday, September 24, 2009 10:53 PM
  • Hello Navit,

    I sent several files as attachments in an email to the address you provided.  If you are able to trace the cause, you can reply to my email, or post it here.  Either way, I'll mark your post as helpful.  If you require other files or info, please let me know.  Further checking on my part follows your suggestion that the problem is not likely in the XaML file itself, but in the project files used in Design, Blend and VS.

    Thanks again,

    BRN..

    BRN Conceptual Vistas, LLC
    Friday, September 25, 2009 5:12 PM
  • Hi,

    I passed along what information I had about this anomaly to the Microsoft MSFT, as they asked.  They were not able to reproduce this occurrence.  It's likely that it was due to a combination of circumstances generated by the use of Expression Design, Blend and Visual Studio, in creating, altering, deleting and saving of projects and files.  If the same issue should arise again, I'll let them know, and post it here.

    As it stands, it's pretty certain that it was not caused by anything in the XaML file itself.  Also, the missing files are accessible when the project is opened in VS (so they were not deleted, only not accessible in Blend).

    I marked the MSFT response as "answer."  If a more complete answer is forthcoming, I'll all to this thread.

    Thank you,

    BRN..
    BRN Conceptual Vistas, LLC
    Monday, September 28, 2009 6:48 PM